Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-18-2013, 04:00 PM
ovation23 ovation23 is offline
Learning to use the forums
 
Join Date: Oct 2013
Posts: 1
Thumbs down 02 ranger 4.0L High rpm idle start, then Dies

My 02 Ranger had an all-of-a-sudden issue yesterday. When i start her up, she turns over, idles at high rpms, for a second, then she slowly studders, then dies . Today, same issue, but no studder, just dies . i plugged the battery, maybe trying to reset any bad sensors, or what not. i had a check engine light go off now and then, reading a small vacuum vapor leak . Maybe it got worst, and that might be the reason, i am new to rangers. Any ideas before i take her in to get looked at, and so i dont get jived. Thank you!
__________________
2002 Ranger 4x4 off road 4.0L
Reply With Quote
Reply

Tags
02 ranger, 4.0l problem, engineissue, highrpmidle, startup

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle / RPM- cold start joro16 3.0 Vulcan Tech 1 08-06-2012 01:18 PM
1996 2.3 L, 5 speed... Cuts out/dies at high RPM, hard acceleration.... Anakritis 4-Cylinder Tech 14 04-09-2012 07:37 AM
96 2.3L 'Chugging' Idle and High RPM to move smacd 4-Cylinder Tech 10 05-31-2011 09:05 AM
High Idle at Start-up tati1036 4.0 SOHC / 4.0 OHV Tech 3 10-24-2010 01:35 PM
PVC/RPM high idle issues 4evermodding 3.0 Vulcan Tech 4 09-05-2010 06:41 PM