Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-03-2009, 09:05 AM
Rangerman Rangerman is offline
Learning to use the forums
 
Join Date: Feb 2009
Posts: 4
Default Running HOTT

I recently just replaced my heater vavle due to a massive crack causing a lot of ani-freeze to leak out. After replaced i put more coolant in( less then a gallon) but i wasnt sure if i had lost it all or not. When i look into the raditator cap there is ussually fluid at the top of it but somtimes i cant even see the coolant. There is also some coolant in the coolant resivor. When the truck warms up the temp guage goes almost 3/4 to H, then after a min or so it will drop to little more then 1/4 the way up from C and then varries between 1/4 warm and a little more then 1/2. The truck still runs fine but i know this cant be good. I dont understand why this is happening. HELP!

Thanks,

Ben
Reply With Quote
  #2  
Old 03-03-2009, 04:03 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

you may have air in the system. try running it with the cap off, not driving just running the air should work its way out
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #3  
Old 03-04-2009, 09:44 AM
Rangerman Rangerman is offline
Learning to use the forums
 
Join Date: Feb 2009
Posts: 4
Default

Yeah i gave that a try and it seems to be working a little bit beter. Do you think that its possible for it to not have enough coolent in it, or is the thermistat maybe not opening all the way?

Thanks for the help
Reply With Quote
  #4  
Old 03-04-2009, 06:54 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

if the coolant is to the full mark that is all you can put in, could be the thermo chep fix but they ussally fail closed or open not the way you are thinking
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.0 major running problems bvallerand 3.0 Vulcan Tech 2 06-26-2009 07:56 PM
wont stay running Lila General Ford Ranger Discussion 4 05-06-2009 04:04 PM
not running right redneck_ranger_1991 2.9 Liter Tech 1 04-26-2009 11:10 PM
2000 Ford Ranger 4.0L running too cold? BrettH8sU General Ford Ranger Discussion 1 02-01-2009 06:38 PM
what would cause my 88 ranger pickup to take long to warm up before running right.? smiles General Ford Ranger Discussion 2 11-26-2008 11:58 PM