Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-21-2010, 03:02 PM
bluerangerftlaud bluerangerftlaud is offline
Liking the Ford Ranger Forum
 
Join Date: May 2009
Posts: 18
Default Near disaster

So a few months ago I decided to install a nice shiny chrome differential cover on my truck.The install went perfect, I resealed it with permatex and filled it back up with gear lube.When I drove it for the first time I put it in gear and it didnt move, then when I hit the gas more it finally moved,which I thought was peculiar.Lately Ive been noticing oil splashed on my rear bumper.I check all the bolts and they are tight and the seal is still intact with no oil around the edges.I then noticed what looked like a seam running down the center of the cover which wasnt there when I installed it.I guess this aftermarket cover was for a Ranger with a smaller gear than my factory 4.10 gears.The ring has eaten almost clear through the cover, which made my truck give off an "oil screen" .as I drove.I was probably spraying cars with oil for weeks .I reinstalled the factory cover and now its fine.Of course I trashed my stock one and had to buy a new one from Ford which was only 2 bucks more than Autozone.Im glad I crawled under there to investigate .
__________________
'02 Ranger Tremor,K&N Intake,Custom Dual Exhaust,Underdrive Main Pulley,
Reply With Quote
  #2  
Old 01-21-2010, 11:59 PM
TheStig TheStig is offline
My truck snorts.
 
Join Date: Sep 2009
Posts: 820
Default

pics?

and you didn't notice it being a little tight when you put it on?
__________________
1996 XLT 2.3T "White Lightning" 5/7 dropped, Turbo street toy
2006 FX4 Off Road, DD, work in progress
1985 XLT 2.8L 4x4 "The Black Pearl" (retired but still around)
1987 XL 2.3L 2wd R.I.P.
Quote:
Originally Posted by RangerAllie View Post
I love me some Stig
Reply With Quote
  #3  
Old 01-25-2010, 08:53 AM
bluerangerftlaud bluerangerftlaud is offline
Liking the Ford Ranger Forum
 
Join Date: May 2009
Posts: 18
Default

Its seemed to fit just fine and the bolts went it flush.Oh well , live and learn
__________________
'02 Ranger Tremor,K&N Intake,Custom Dual Exhaust,Underdrive Main Pulley,
Reply With Quote
  #4  
Old 01-28-2010, 06:53 PM
Brutus318 Brutus318 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 12
Default

Something to laugh about now, but dern that thing woulda looked nice, huh?
__________________
1996 2.3 5-speed. Nothing special, just a daily driver, but I'm looking to make some improvements on driveability. Oh, and it's a Mazda. Hope that doesn't hurt any feelings!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search