Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-04-2012, 07:38 PM
mazda12 mazda12 is offline
Learning to use the forums
 
Join Date: Feb 2012
Posts: 11
Default Tranny problem? 2001 B4000

Hey everyone..
Bought the truck a year ago and am not the 4th owner, the truck is being past like a rag doll. I am in love with it but am worried bout the transmission. NO FIRST GEAR/LOW GEAR. even second slows the truck down more..

Although when 4x4 is engaged First gear does work...
Is this just the way mazdas are? will it lead to further problems!

Thanks!
__________________
2001 MAZDA B4000 SE... K&N, throttle body spacer, Torsion Crank, 3" Body lift, 33" KM2s (summer), rhino liner undercarriage, 10" sub in a custom box, amp, deck, outer temp gauge, custom front hooks, rancho 9000's
Reply With Quote
  #2  
Old 03-04-2012, 07:46 PM
2wdedge 2wdedge is offline
Ford Ranger Driver
 
Join Date: Mar 2011
Posts: 1,358
Default Re: Tranny problem? 2001 B4000

Is this an automatic in your truck?

----------

If it is see the thread going on now "shifts hard into 3rd gear" in Drivetrain Tech, may be of some help.
__________________
2002 Edge Super Cab 3.0, 2wd, air box mod ,3.73
L/S,Torsion Lift, 31x10.50x15 Tires, Leer Bed Cap

Last edited by 2wdedge; 03-04-2012 at 07:50 PM.
Reply With Quote
  #3  
Old 03-04-2012, 07:51 PM
mazda12 mazda12 is offline
Learning to use the forums
 
Join Date: Feb 2012
Posts: 11
Default Re: Tranny problem? 2001 B4000

yeah sorry i forgot, it is automatic!

thanks for the reply ill be sure to check that out!
__________________
2001 MAZDA B4000 SE... K&N, throttle body spacer, Torsion Crank, 3" Body lift, 33" KM2s (summer), rhino liner undercarriage, 10" sub in a custom box, amp, deck, outer temp gauge, custom front hooks, rancho 9000's
Reply With Quote
  #4  
Old 03-04-2012, 07:55 PM
2wdedge 2wdedge is offline
Ford Ranger Driver
 
Join Date: Mar 2011
Posts: 1,358
Default Re: Tranny problem? 2001 B4000

Yeah, it could be something as simple as a fluid and filter change, also, check the valve body gaskets, they do go bad and the valve body will loose pressure...
__________________
2002 Edge Super Cab 3.0, 2wd, air box mod ,3.73
L/S,Torsion Lift, 31x10.50x15 Tires, Leer Bed Cap
Reply With Quote
  #5  
Old 03-05-2012, 11:06 PM
mazda12 mazda12 is offline
Learning to use the forums
 
Join Date: Feb 2012
Posts: 11
Default Re: Tranny problem? 2001 B4000

k so i did a lot of playing around with the gears today IT DOES go into low gear and accelerates with increasing rpm... BUT when i go down a hill it is as if it is in neutral. RPMS all around 1000!!! i think i will be taking it into a tranny specialist
__________________
2001 MAZDA B4000 SE... K&N, throttle body spacer, Torsion Crank, 3" Body lift, 33" KM2s (summer), rhino liner undercarriage, 10" sub in a custom box, amp, deck, outer temp gauge, custom front hooks, rancho 9000's
Reply With Quote
Reply

Tags
mazda 4x4 problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
tranny problem cowboypa69 Drivetrain Tech 0 02-29-2012 02:17 PM
1999 b4000 hub problem afferable1 Drivetrain Tech 0 02-25-2012 02:56 PM
tranny problem purovalluco01 Drivetrain Tech 0 01-09-2012 06:57 PM
Tranny problem? 03 Ranger Drivetrain Tech 0 09-24-2011 02:44 PM
Changing tranny fluid and filter on 2001 4.0 mike01 4.0 SOHC / 4.0 OHV Tech 2 05-27-2010 06:16 PM