Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-05-2012, 12:02 PM
krunchdoc krunchdoc is offline
Learning to use the forums
 
Join Date: Feb 2012
Posts: 1
Exclamation New ranger owner HELP!

so long n short of it, my g-father passed and left me his '04 4x4 xlt,.. i like tuning so i thought id stat basic and put a new intake and filter in ( on top of other upgrades).. but now after installed properly. ( note, i have installed many on smaller jap cars as a racing youth, so i know how to put a intake in ) it wont keep running and loses revs and then pops on again.. ilet it run for a while to let the comp learn but am i missing something on my new ranger? Any help would be very very appreciated. i had to join the forum qwik to try and find answers, so i dont have a profile yet.... but will soon got some nice pic's of the little lady.. ty again folks... ps. im under the hood as im typing so the faster the better... greatest early thanks Ranger Crew!
__________________
2004 4x4 xlt
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Long time Ford owner, 1st time Ranger owner jumpinjack Introduce Yourself 8 11-11-2011 04:14 AM
Maybe X Ranger Owner dewking General Ford Ranger Discussion 60 02-23-2011 06:28 PM
new ranger owner inkman1989 Introduce Yourself 8 01-09-2011 12:45 PM
New Ranger Owner joshman88 Introduce Yourself 11 10-02-2010 05:14 PM
New Ranger owner from WY Nathyrin Introduce Yourself 15 04-18-2010 05:18 AM