Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-09-2009, 12:41 PM
mossyoakgirl6564
Guest
 
Posts: n/a
Default I have a 94 ford ranger v6 3.0 it cranks but it wont start?

I recently replaced the clutch slave cylinder and the clutch master cylinder. After that I replaced the ignition control module, ignition coil, and distributor cap. It still wont start. I need help?
Reply With Quote
  #2  
Old 01-09-2009, 12:41 PM
MARCUS N
Guest
 
Posts: n/a
Default

Check fuel pressure and compression in each cylinder. Also can be crankshaft position sensor.
Reply With Quote
  #3  
Old 01-09-2009, 12:41 PM
cab7784
Guest
 
Posts: n/a
Default

check to see if ignition module is sparking. pull a plug wire, if it has one and lay it next to plug have a buddy try to turn. if it sparks your ok if not then get it tested. If you get it tested have them test it about 10 times and if it fails once get a new one. I had that problem with the module before. it pass 5 times before 1 fail. everything above you did should rule out alot of things it could be. not your ignition switch because it cranks. check plugs, check wires may accidentally crossed. check to see if you have gas. check fuel filter, may be clogged. fuel pump may not be pumping and pressurizing system to turn over.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 SOHC L4 engine cranks but won't start esp2009 General Tech 6 06-14-2012 07:09 PM
99 ford ranger wont start? Chase E General Ford Ranger Discussion 2 07-31-2009 11:36 PM
1995 ford ranger wont start? Chris General Ford Ranger Discussion 4 01-25-2009 10:22 AM
86 ford ranger wont start? matt l General Ford Ranger Discussion 2 01-23-2009 07:50 PM