Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 12-03-2009, 07:32 PM
rwenzing rwenzing is offline
Some assembly required...
Join Date: Jun 2009
Posts: 888

Ok, then that might mean one of several things:

There is a problem with the brown/white wire from the low range bulb, specifically a short to ground somewhere.
There's a problem with the Electric Shift Control Module.
Something else I haven't thought of.

Sorry but, the way I see it, there is nothing in the symptoms that points directly to a specific problem and solution.

I would start by pulling the pushbutton panel and doing a visual inspection. Look for broken or pinched wires or corrosion at the connectors. Next, I would do the same at the Electric Shift Control Module (left rear corner of the cab, probably under a trim panel).
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab beater, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
i want to lift my ranger help bigkehoe Lifted Suspension 2 07-06-2009 06:53 AM