Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-18-2009, 04:18 AM
dynamo04 dynamo04 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 9
Default Rear parking/tail lights don't work.

Have a 94 Mazda B4000LE Pickup (Same as 94 Ranger XLT)

Neither rear parking light works; the brake lights work as well as the backup and directionals.
Have replaced both 3157 bulbs; doesn't appear to be a fuse as the license plate lights work and the brake lights.

Any thoughts?

Thanks!

Last edited by dynamo04; 11-18-2009 at 11:43 AM.
Reply With Quote
  #2  
Old 11-19-2009, 12:37 AM
dynamo04 dynamo04 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 9
Default

Can anyone please help?

Any ideas would be appreciated.
Reply With Quote
  #3  
Old 11-19-2009, 04:45 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default

The parking lamp filaments of the tails are on the same brown wire and fuse and ground as the license plate lights. So, if the LPLs work, then you know that the problem lies at the rear of the truck - bulbs, bulb sockets or wiring. Try opening the 8-pin connector at the rear of the frame and check for loose pins or corrosion.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #4  
Old 11-19-2009, 05:54 AM
dynamo04 dynamo04 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 9
Default Thanks rwenzing!

Appreciate your response.

Replaced both of the 3157's so it doesn't appear to be the bulbs.
One of the lamp sockets is brand new and that side still doesn't work.

Exactly where would I find the 8-pin connector?

Thanks again,
Paul
Reply With Quote
  #5  
Old 11-19-2009, 06:12 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default

Look around under the box near the back end of the frame. I don't have a 94 here to look at but it could be on the inside rear of the left frame rail.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #6  
Old 11-19-2009, 06:20 AM
dynamo04 dynamo04 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 9
Default Thanks!

And yes, the LPL's both work.

Will look for the 8 pin Connector.
Reply With Quote
  #7  
Old 11-19-2009, 06:55 AM
dynamo04 dynamo04 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 9
Smile Thank you rwenzing!

THANK YOU; THANK YOU; THANK YOU; THANK YOU.

That was exactly it.
Located the connector, cleaned it with some Electronic Cleaner and now they both work.

FIXED; wow am I happy; thanks so very much,
Paul
Reply With Quote
  #8  
Old 11-19-2009, 10:33 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default

Glad to help.

The fix will probably last a lot longer if you squeeze some dielectric grease into the connector. It helps keep water, salt and air away from the metal pins. I use it anytime I have a connector open.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #9  
Old 11-19-2009, 11:13 AM
dynamo04 dynamo04 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 9
Default

Thanks for that advice; will do that!

Paul
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 93-99 Ranger LED tail lights & 01-05 halo projector fog lights j$wift Exterior Parts 5 08-04-2010 08:05 PM
09 Tail lights jakewolford Exterior Tech 10 11-17-2009 08:28 PM
Parking Lights not working pmason858 Electrical Tech 3 10-06-2009 09:13 AM
New Tail Lights! DakotaRanger Exterior Tech 7 09-30-2009 01:33 PM
Instrument Cluster/Tail Lights/Fog Lights - NO Lights when Headlamps are on??? bwheeler Electrical Tech 6 06-05-2009 05:35 AM