Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-14-2009, 03:57 PM
velozp velozp is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 41
Question CPP problem?

Hello everyone I am new to this site. I have a 99 ranger 2.5 2wd 5 speed. With the clutch depressed, the truck wont start ( wont even pull over) but if you push the truck and have someone pop the clutch in gear, the truck will start everytime. I did see on this sight maybe a starter solenoid relay, or a CPP ( clutch pedal position) switch, or fuse # 24. that may cause this. Any ideas where I should start debuggging this? Thank you so much.
Reply With Quote
  #2  
Old 11-14-2009, 05:50 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

there is a relay ($6) in the distribution box on the drivers side fender in the engine compartment.for $6 proabably not a bad start. you might even be able to switch with another one in the box and i think there is a fuse in the box also. then the starter interlock switch that you mentioned as well as possibly the ignition switch. have you checked to see if you have power at the starter. any other symptoms?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 11-14-2009, 05:55 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

if you don't have an owners manual you can go here to get one go to maintenance and then owners man you can find out where the fuses and relays are https://www.fleet.ford.com/nual
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 11-15-2009, 06:15 AM
velozp velozp is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 41
Default

Thank you I will try these things today
Reply With Quote
  #5  
Old 11-18-2009, 02:52 AM
velozp velozp is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 41
Default CPP problem fixed

Quote:
Originally Posted by velozp View Post
Hello everyone I am new to this site. I have a 99 ranger 2.5 2wd 5 speed. With the clutch depressed, the truck wont start ( wont even pull over) but if you push the truck and have someone pop the clutch in gear, the truck will start everytime. I did see on this sight maybe a starter solenoid relay, or a CPP ( clutch pedal position) switch, or fuse # 24. that may cause this. Any ideas where I should start debuggging this? Thank you so much.
Hi guys thanks for the help. It ended up being a rusted wire off the starter. Unfortunatly the connection on the started broke. It looks like the stater was under the sea. 250 bucks later for a new starter and Im on the road. Good ol NE winter with road salt. However I did learn some stuff about my truck if this problem shows up. Thanks again to modelageek
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search