Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-28-2011, 07:58 PM
98Green Machine 98Green Machine is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 10
Default Help on the sound system

i just got my new amp in its a 1500 watt powering 2 12 inch treo subs and it was thumping for like 10 minutes not stop and then i got to drive to the store and my hole sound system wasnt working and on the head unit it said protect and i tryed every thing and it still isnt working
Reply With Quote
  #2  
Old 07-28-2011, 08:09 PM
Drexl Drexl is offline
Banned
 
Join Date: Jan 2011
Posts: 752
Default Re: Help on the sound system

reset the head unit... but it sounds like one of your speakers are blown.. or theres a short in the wiring.
Reply With Quote
  #3  
Old 07-28-2011, 08:20 PM
Major376 Major376 is offline
that guy you know kinda
 
Join Date: Dec 2010
Posts: 186
Default Re: Help on the sound system

mine did that, my amp didnt have a built in fan and it got hot and my speakers would shut off, along with my stereo.
__________________
1985 Ranger 2.3l L4 stock with ghetto exhaust and moon visor gone :/
1986 ranger 4x4 3-5" lift?,30x10.50 pathfinder radials, front bush bumper, 300inline 6 swap (In progress)
Reply With Quote
  #4  
Old 07-28-2011, 08:23 PM
98Green Machine 98Green Machine is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 10
Default Re: Help on the sound system

i reset the head unit and the amp is getting no power... is there a fuse blown
Reply With Quote
  #5  
Old 07-28-2011, 08:56 PM
zach2323 zach2323 is offline
Ford Truck Driver
 
Join Date: May 2011
Posts: 91
Default Re: Help on the sound system

Quote:
Originally Posted by 98Green Machine View Post
i reset the head unit and the amp is getting no power... is there a fuse blown
its possible. check your in line fuse(s)
Reply With Quote
  #6  
Old 07-28-2011, 09:30 PM
98Green Machine 98Green Machine is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 10
Default Re: Help on the sound system

there is a little tube with the power cord to the amp from the battery or fuse box... would that be it
Reply With Quote
  #7  
Old 07-29-2011, 08:12 AM
zach2323 zach2323 is offline
Ford Truck Driver
 
Join Date: May 2011
Posts: 91
Default Re: Help on the sound system

sounds like it. you should be able to take it apart and a fuse should be inside. if its blown you should be able to tell.
Reply With Quote
  #8  
Old 07-29-2011, 08:57 AM
FFparker FFparker is offline
Shamrock
 
Join Date: Jan 2011
Posts: 3,644
Default Re: Help on the sound system

If the fuse is round on the power wire it might not look blown but if it is it should look "popped" if you can understand that. check fuses in the amp too.
__________________
GOLDIE
1999 2.5L XLT
Herculiner | Kobalt tool box | K&N Filter | 6k HID's | 31's BFG | Eagle Alloy 186s | 102'' Whip | Cobra 19 DX IV | Fabtech 3.5 Spindles | Pro Comp AAL kit | 15% Tint | Mustang Dome
Reply With Quote
  #9  
Old 07-29-2011, 03:27 PM
98Green Machine 98Green Machine is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 10
Default Re: Help on the sound system

yeah it turns out that i am not running big enough wire i am having to rerun the wires and up it to 4 gauge wire and the fuse was blown and thanks for all the help
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound system help blepard Audio / Video 7 07-11-2011 06:10 PM
Holy shit sound picking out my sound system is overwhelming! Fordranger2001 Audio / Video 20 09-22-2010 01:19 PM
Help with a sound system AwesomeMcBadass Audio / Video 19 09-08-2010 08:04 PM
sound system help smsranger Audio / Video 21 03-31-2010 12:01 PM
Sound System pmac Audio / Video 11 12-24-2009 11:33 AM