Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-16-2011, 03:36 PM
christiancarpenter christiancarpenter is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 8
Default carb question

got this 83 2.3 single barrel. not sure of the carb numbers. on the side is a little cylinder thing with 2 wires going into it.

A: should it make a clicking sound when the key is on? what is that cylinder for?

B: the guy put an electric fuel pump on it and removed the mechanical. how much fuel does the carb need? the pump is a slow stream...

ran fine when i got it but today it won't make it around the block without sputtering out. figures, as soon as i put insurance on it and register it that it poops out. btw, the filters look new. it has a morosso fuel reg (dial kind) on it that doesn't seem to do anything when i turn it. wondering if that is clogged up a bit. any advice would help. thanks.
Reply With Quote
  #2  
Old 07-16-2011, 03:41 PM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: carb question

It's been too damn long since I worked on a carburetor to be much help. I think A is a solenoid of some some sort. It might have something to do with then the engine is running cold but that's the best I can give you.

I never had a vehicle with a carb and an electric fuel pump, so I don't have squat for you there. Good luck.

Hopefully someone with more recent experience can chime in for you.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #3  
Old 07-16-2011, 04:32 PM
christiancarpenter christiancarpenter is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 8
Default Re: carb question

thanks bro. i appreciate it anyway. i pulled the inline filters off (one at the carb the other right before the fuel pump) and even though it looked brand new, the one at the pump was loaded with crap. i put the other one there and the pump started kicking out about 3 times as much fuel so i think that may have been the problem. off to my flaps to get another filter now. hoping that's all it is. i'm thinking i might better flush that tank out at some point. it the filter was that new and all gummed up, the tank may be filthy. thanks again. maybe some pics when i get home.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3L FI and 2.3 CARB WildlandFirefighter 4-Cylinder Tech 6 08-24-2011 07:13 PM
YFA carb issue joebee49 4-Cylinder Tech 2 05-24-2011 01:33 PM
Carb adjustment jostrickland 4-Cylinder Tech 1 03-26-2011 05:04 PM
'83 2.3L YFA Carb Problems (CARB GURU REQUIRED) Gumcrew2 4-Cylinder Tech 0 03-04-2011 04:43 PM
2.0 carb? mudboat 4-Cylinder Tech 0 07-05-2010 09:20 AM