Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-10-2011, 11:10 AM
74Ironhead 74Ironhead is offline
Learning to use the forums
Join Date: Jul 2011
Posts: 5
Default 01 Ranger 4.0 rough idle, grey smoke, won't stay running HELP

I am a new member and have a problem I have no idea how to fix. I hope someone can help. I have a 01 Ranger 4.0. It drove fine all day and the next morning when I went to start it, it had a rough idle, grey smoke from exhaust and it will not stay running. It idles at 100 RPM. I have replaced the fuel filter, egr valve and celenoid, coil pack and cleaned the iac valve and maf sensor. Also not leaking anything and no antifreeze in oil. All with no avail, it still does the same thing. Any suggestions would be GREATLY appreciated. Thanks so much!

2001 Ranger XLT 4x4. Color Black, tinted windows, Stock Motor, 2" Lift with 33x11.5 on 15" steel rims.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
ranger 2.3L running rough when warm bmason61 4-Cylinder Tech 1 04-11-2011 07:06 AM
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE Chargerondavins 3.0 Vulcan Tech 1 03-26-2011 04:54 PM
84 2.8L V6 idle is too low to stay running OreEle 2.9 Liter Tech 5 11-10-2010 06:38 AM
2.3l duratech rough idle & smoke. wont start now jrg24 4-Cylinder Tech 1 10-03-2010 03:32 PM
Why wont my 4.0L Ford Ranger stay running when cold? NeonBoy95 Drivetrain Tech 4 08-29-2010 02:47 AM