Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-05-2011, 09:20 PM
karissabug124 karissabug124 is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 23
Question Already having issues, HELP!

ok so ive had the truck for a week now yesterday..

it's lagging when it starts (doesnt wanna turn over right away) <-- like it used too.

& ONLY AT NIGHT when the lights are turned on and i'm driving the green lights in the radio were it displays the station ( etc ) like to flicker.. after they flicker the radio will start to fade in & out .
BUT, it only happends at night. weird, help mee !!
Reply With Quote
  #2  
Old 07-05-2011, 09:21 PM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: Already having issues, HELP!

do you ever drive w ur lights on during the day? just asking
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #3  
Old 07-05-2011, 09:31 PM
karissabug124 karissabug124 is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 23
Default Re: Already having issues, HELP!

nope, think it could be an electrical short?
Reply With Quote
  #4  
Old 07-05-2011, 09:47 PM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: Already having issues, HELP!

it could be, but i believe shorts automatically blew fuses..at least in my expierence, could be a connection issue (i doubt it has ANYTHING to do w nighttime driving lol ur headlights...maybe) so check ur connections on the back of the stereo and other places u think it could be from, ie: headlights and stuff like


the lagging...no effin idea but thats the good thing about frf..they solve SHIT, believe me i know

----------

i recommend editing ur title to be more clear about your issue

go to edit post, go advanced, change title to something better...it may not (new title) show up on the new posts right away tho..a glitch the site has
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #5  
Old 07-05-2011, 09:49 PM
2004xlmiller 2004xlmiller is offline
Ford Ranger Driver
 
Join Date: Jun 2010
Posts: 12,689
Default Re: Already having issues, HELP!

the bad start up could be a faulty starter. how many miles on this?

as for the stereo, the dimmer switch could be at fault, but its probably a bad connection with the radio plug, open it up and check the back.
Reply With Quote
  #6  
Old 07-05-2011, 09:52 PM
FordDude1991 FordDude1991 is offline
Turkey Hill Superstar
 
Join Date: Jan 2011
Posts: 1,045
Default Re: Already having issues, HELP!

have you done a tuneup lately?
__________________
Dave K
2011 Ford Ranger 4x4 Sport 4.0L "Dixie"
Rancho Suspension/Auto/3.73's/Pinstriped/Flowmaster SS Exhaust.

FUTURE: 3' Body Lift/32's/Windshield Visor/Brush Guard.
Reply With Quote
  #7  
Old 07-05-2011, 09:57 PM
2004xlmiller 2004xlmiller is offline
Ford Ranger Driver
 
Join Date: Jun 2010
Posts: 12,689
Default Re: Already having issues, HELP!

Quote:
Originally Posted by FordDude1991 View Post
have you done a tuneup lately?
x2
Reply With Quote
  #8  
Old 07-05-2011, 10:27 PM
Rg1Baja Rg1Baja is offline
DirtFreeks Mtrspts #7299
 
Join Date: May 2011
Posts: 180
Default Re: Already having issues, HELP!

Loose ground wire? Check the battery?
__________________
DirtFreeks Motorsports
Reply With Quote
  #9  
Old 07-06-2011, 01:19 PM
karissabug124 karissabug124 is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 23
Default Re: Already having issues, HELP!

Quote:
Originally Posted by FordDude1991 View Post
have you done a tuneup lately?
It only has 58,000 miles on it, and I just bought it from a dealer so! all of the tunning was just done !
Reply With Quote
  #10  
Old 07-06-2011, 01:30 PM
brinker88 brinker88 is offline
TTB man
 
Join Date: Aug 2010
Posts: 1,920
Default Re: Already having issues, HELP!

sounds like an alternator to me with a bad charge (not keeping the voltage constant-flickering)
__________________
1993 Ford Ranger Ext. Cab | stepside | 4x4 | 4.0L | Lifted | 35" BFG KM2s | MT Classic IIs | Dana 35/Disc 8.8 with 4.56's | Duals | Etc

RIP JASON
Reply With Quote
  #11  
Old 07-06-2011, 04:21 PM
Drexl Drexl is offline
Banned
 
Join Date: Jan 2011
Posts: 752
Default Re: Already having issues, HELP!

Quote:
Originally Posted by brinker88 View Post
sounds like an alternator to me with a bad charge (not keeping the voltage constant-flickering)
+1
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
4x4 issues nehelt1973 Electrical Tech 3 04-01-2015 09:06 AM
Coolant issues once again DeckedOut 4-Cylinder Tech 7 01-31-2011 08:44 AM
Shifting Issues somidscr21 4-Cylinder Tech 6 01-19-2011 12:58 PM
Stalling issues. Superlifted06FX4 4-Cylinder Tech 1 06-17-2010 07:30 PM
issues jjanak79 Drivetrain Tech 0 01-11-2010 03:19 PM