Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-26-2011, 11:11 AM
arizaino arizaino is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 12
Question Thermostat change - now runs lousy

I have changed my thermostat in my 99 - 4.0 ranger with 238,000 miles. I noticed temp gauge up towards the top...I ran the heater while driving and temp gauge came down to about 3/4. I figured the water pump was pushing water through the block but, not the radiator. With that said, I replaced the t-stat and all is good again....except...now my truck runs lousy. When I replaced the t-stat, I unplugged the MAF sensor, moved the air intake tube out of the way. I changed the t-stat and put the air intake tube back in place and re-installed the MAF sensor plug. The motor ran fine before I started the job, now, it runs pretty bad and the check engine light is on. Would this be something to do with the computer? Do I have another issue? Not sure what could have happened. Pretty simple job.
Reply With Quote
  #2  
Old 06-26-2011, 11:22 AM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: Thermostat change - now runs lousy

Have the code read. It will tell you what it found.

By lousy, do you mean it idles funny? How lousy is lousy?
Reply With Quote
  #3  
Old 06-26-2011, 11:50 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Thermostat change - now runs lousy

I'd be willing to bet there is something electrical or vacuum not plugged back in from when you were working on it.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #4  
Old 06-26-2011, 04:32 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Thermostat change - now runs lousy

If it was running perfectly fine before, I doubt 238,000 fucking miles just all of sudden caught up with it coincidentally at the same time as changing the thermostat.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 06-26-2011, 04:39 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: Thermostat change - now runs lousy

Quote:
Originally Posted by FireRanger View Post
If it was running perfectly fine before, I doubt 238,000 fucking miles just all of sudden caught up with it coincidentally at the same time as changing the thermostat.
I can agree with this.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #6  
Old 06-26-2011, 04:42 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: Thermostat change - now runs lousy

If you can get the computer scanned see if it is throwing a code.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #7  
Old 06-26-2011, 04:55 PM
mmxchamp mmxchamp is offline
10-32
 
Join Date: May 2011
Posts: 74
Default Re: Thermostat change - now runs lousy

if you can't check your codes, might try unplugging your battery for awhile to clear the codes. your computer might have freaked out cause the MAF was unplugged or its just learned to run really hot? I dunno, just throwing thoughts out there.
__________________
'05 2.3l, Single cab, 5 speed manual - Headlight Mod, Blinker Mod, Mustang Dome Light, Explorer Overhead Console, Partial Grille Block
Add me!
Reply With Quote
  #8  
Old 06-26-2011, 06:48 PM
arizaino arizaino is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 12
Default Re: Thermostat change - now runs lousy

Quote:
Originally Posted by mmxchamp View Post
if you can't check your codes, might try unplugging your battery for awhile to clear the codes. your computer might have freaked out cause the MAF was unplugged or its just learned to run really hot? I dunno, just throwing thoughts out there.
Thank you...I'm thinking this sounds logical. I will give it a try and post the results. 238,000 well taken care of miles....should go another 238,000! New upper and lower ball joints, clutch, u-joints - and of course regular maintenance (oil,filters,coolant,brakes,tires,belts,hoses etc...)

----------

Quote:
Originally Posted by Drexl View Post
Weird things happen.. That's a ton of miles.. you can't say you don't think that engine has gotta be near the end of it's useful life
Not even close
Reply With Quote
  #9  
Old 06-26-2011, 06:49 PM
FX4OR FX4OR is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 417
Default Re: Thermostat change - now runs lousy

^ that's where i'd start. its most likely some dumb simple thing lol.
congrats on those high miles too, that's pretty rad.
__________________
2002 Ranger FX4
4.0L SOHC, 5R55E Auto, 4.10 8.8 Torsen, 31x10.5/15 BFG ATs
Reply With Quote
  #10  
Old 06-26-2011, 06:50 PM
arizaino arizaino is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 12
Default Re: Thermostat change - now runs lousy

Quote:
Originally Posted by Fordzilla80 View Post
Have the code read. It will tell you what it found.

By lousy, do you mean it idles funny? How lousy is lousy?
Yeah...I would say idles funny...almost sounds like it's missing a bit.

----------

Quote:
Originally Posted by FX4OR View Post
^ that's where i'd start. its most likely some dumb simple thing lol.
congrats on those high miles too, that's pretty rad.
Thanks...gotta keep er runnin for a while longer. Gotta pay off the Harley before I can buy another vehicle...thinkin an 08 Bullitt
Reply With Quote
  #11  
Old 06-26-2011, 06:51 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Thermostat change - now runs lousy

You can look for things disconnected without a code reader. You pulled stuff apart to reach the thermostat. Something is probably just not plugged back in. A hose or wire. Look around.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #12  
Old 06-26-2011, 06:51 PM
mmxchamp mmxchamp is offline
10-32
 
Join Date: May 2011
Posts: 74
Default Re: Thermostat change - now runs lousy

If that doesn't work and you still have a check engine light and/or it runs bad, you might have to go to an autoparts store and have them check the code for you. Have you ever replaced the MAF or cleaned it?

thats an impressive amount of miles!! how much oil does it burn? I had an aerostar with the 3.0L vulcan motor; it was at 212,000 miles when i got rid of it and the only problem was it burned a quart of oil every 1,000 miles or so. I'm tired of buying stuff that was used; since I'm still in school its kinda my only option though. I can't wait to buy a new car so I know its been taken care of properly!
__________________
'05 2.3l, Single cab, 5 speed manual - Headlight Mod, Blinker Mod, Mustang Dome Light, Explorer Overhead Console, Partial Grille Block
Add me!
Reply With Quote
  #13  
Old 06-26-2011, 06:52 PM
zdorfman zdorfman is offline
Like the Forums
 
Join Date: Feb 2011
Posts: 41
Default Re: Thermostat change - now runs lousy

Drexl is just looking for attention and the only way he knows how to get it is by being negitive and just plain mean.

make sure you dont have vacuum leaks, thats all i can think of that could change as a result of switching out a thermostat maybe you un hooked something and just forgot to hook it back up in the process.
Reply With Quote
  #14  
Old 06-26-2011, 06:52 PM
FX4OR FX4OR is offline
Ford Tough
 
Join Date: Dec 2010
Posts: 417
Default Re: Thermostat change - now runs lousy

that sounds like something's up with the maf. it doesn't know how much air is entering the engine, and the idle bounces.
__________________
2002 Ranger FX4
4.0L SOHC, 5R55E Auto, 4.10 8.8 Torsen, 31x10.5/15 BFG ATs
Reply With Quote
  #15  
Old 06-26-2011, 06:55 PM
north44 north44 is offline
Ford Truck Driver
 
Join Date: Jan 2010
Posts: 77
Default Re: Thermostat change - now runs lousy

Quote:
Originally Posted by FireRanger View Post
I'd be willing to bet there is something electrical or vacuum not plugged back in from when you were working on it.
This is good advice - retrace your steps - you could easily have knocked something loose. E.g., look at the vacuum lines to the vacuum reservoir - they're easily disconnected any time you work on something under the hood.
__________________
2003 Supercab Flareside
4 liter V6
4x4 FX4 Level I
5 speed Auto
4.10 LS Rear
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermostat help.... eric248 4-Cylinder Tech 6 06-02-2011 07:23 AM
change thermostat redranger98 4-Cylinder Tech 3 05-15-2011 04:05 PM
thermostat? quatro puertas05 4-Cylinder Tech 12 07-17-2010 03:14 PM
thermostat Turtle 4-Cylinder Tech 8 06-07-2010 12:16 PM
Lol, where is my thermostat? rumpranger 4-Cylinder Tech 3 01-01-2010 08:38 PM