Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #31  
Old 06-29-2011, 04:43 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Thermostat change - now runs lousy

Quote:
Originally Posted by knightmare1015 View Post
That's a great read right there man. Good old STL. That should be a sticky thread instead of being closed.
It is closed because it is just a how to article. There is a discussion thread just for it.
__________________
2005 Edge

Reply With Quote
  #32  
Old 07-16-2011, 12:17 PM
arizaino arizaino is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 12
Default Re: Thermostat change - now runs lousy

Okay....so here it is.....sorry it took so long to get back......the problem had nothing to do with the MAF sensor, t-stat, hoses etc...The problem turned out to be a fuel injector wire come lose....on the opposite side of the engine. Coinsidence !! Go figure. I want to thank everyone for the ideas and suggestions. This is a great place for information. Drive Safe !
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermostat help.... eric248 4-Cylinder Tech 6 06-02-2011 07:23 AM
change thermostat redranger98 4-Cylinder Tech 3 05-15-2011 04:05 PM
thermostat? quatro puertas05 4-Cylinder Tech 12 07-17-2010 03:14 PM
thermostat Turtle 4-Cylinder Tech 8 06-07-2010 12:16 PM
Lol, where is my thermostat? rumpranger 4-Cylinder Tech 3 01-01-2010 08:38 PM