Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-10-2018, 01:19 PM
fishrich fishrich is offline
Learning to use the forums
 
Join Date: Jul 2018
Posts: 1
Default 96 ranger low bem not working. Bulb is good

Hello guys my name is fishrich. I have a 96 ranger and the low beam on the drivers side does not work. I have tried the bulb from the other side which is good and nothing. Im thinking its a fuse but I don't know which one, Can you help?
Reply With Quote
  #2  
Old 07-11-2018, 12:36 AM
Undrstm8ed Undrstm8ed is offline
Habenae Est Dominatus
 
Join Date: Apr 2013
Posts: 1,535
Default Re: 96 ranger low bem not working. Bulb is good

The owners manual has a fuse layout but it could also be a relay in the underhood box too.

You didnt mention which engine so that will alter the configurations some for the requested info you seek.
__________________
"The slave is held most securely when he is held by the chains of his own will and of his own fears, and when he is locked down by his own slavish desires for a comfortable life." - Michael Bunker

- 93' Ranger, Overland Build thread http://www.fordrangerforum.com/proje...ing-build.html - 12 North Industries
Reply With Quote
  #3  
Old 07-13-2018, 04:13 PM
tiredretired tiredretired is offline
29 Year Ranger Veteran
 
Join Date: Oct 2013
Posts: 264
Default Re: 96 ranger low bem not working. Bulb is good

My low beam quit working on the passenger side only. High beam was OK. I simply ran a wire over from the low beam on the drivers side.

Now running Morimoto projectors so it all became a moot point with relays and such.
__________________
2005 Ranger FX/4 4.0 Auto. 156K.

Ceramic Pads, Energy Suspension Polyurethane Sway links and bushings. OHC. Third Brake Light Directionals. KYB Shocks. Dipped and Blacked Out.

Acme Projectors with Morimoto XB35 Ballast and Morimoto XB35 5500K Bulbs.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver side low beam not working but bulb is good. biscuitboy9123 Electrical Tech 2 09-10-2017 07:53 AM
CEL Light not Working; Replaced Bulb Ranger4x4.0 General Ford Ranger Discussion 0 03-21-2017 09:45 PM
*No Check Engine Light* Bulb is Good miljeep66 4-Cylinder Tech 4 05-28-2012 03:35 PM
Working on Good Friday nashvegas Off Topic 33 04-22-2011 04:32 PM
Looking for a good working 4 cylinder alternator for a 95 ranger 4banger Engine & Drivetrain Parts 5 10-25-2009 10:33 PM