Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-08-2008, 11:55 AM
njs811271
Guest
 
Posts: n/a
Default I have a problem with my Ford Ranger Truck?

At first the truck would rarely start. and when it did it wasn't long before it cut out. I replaced the spark plugs, got a new distributer for it. and i'm absolutely sure its not the alternator. now the truck starts on occasion, but eventually shuts off. Other than that, it wont start at all. Does anyone have a solution to whats wrong with my Ford Ranger Truck?

Its also a stick shift if that helps.
engine i'm not sure of. but I know its an 88. so yea its 20 years old.
Reply With Quote
  #2  
Old 12-08-2008, 11:55 AM
Charlie
Guest
 
Posts: n/a
Default

What year, engine? Check fuel and check for spark. Might be electronic ignition module, all kind of possibilities without knowing what year and engine.
Reply With Quote
  #3  
Old 12-08-2008, 11:55 AM
Scott R
Guest
 
Posts: n/a
Default

You have either the 2.3 4 cyl or the 2.9 V6.

Get an ACTRON scanner, about $30, and follow the directions to hook it up and test the vehicle.

It sounds like a fuel delivery problem since you replaced the ignition already.
Reply With Quote
  #4  
Old 12-08-2008, 11:55 AM
Old Man Dirt
Guest
 
Posts: n/a
Default

When was the last time you replaced your fuel filter?
Reply With Quote
  #5  
Old 04-11-2009, 09:30 AM
i0wafarmer13 i0wafarmer13 is offline
Learning to use the forums
 
Join Date: Apr 2009
Posts: 11
Default

i had the same problem with my 87. check the #4 sparkplug wire on the distributor and also look aroun the carb for vacuum lines that are unplugged. my trck was down for a year because the mechanic told me it was a valve when all it was was a spark plug wire and a vaccuum line.
Reply With Quote
  #6  
Old 04-11-2009, 11:31 AM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

make sure you have fuel pressure and spark
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/
Reply With Quote
  #7  
Old 04-13-2009, 09:39 AM
richard richard is offline
Learning to use the forums
 
Join Date: Apr 2009
Posts: 2
Default

i had a simular problem with a range rover v8 .it would run for about 10 minutes and then died .it would still spin on the starter but would not re start .if you charged the battery over night it would restart run for 10 then die .changed ignition module. distributor base plate .ignition coil ect .exactely the same .spin on the starter but no go . in the end i cleaned every earth lead from battery to engine put a new battery on it and never had the problem again.the old battery would turn it over fairly fast which made it even more confussing hope this may be of help
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search