Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-12-2011, 02:03 PM
navseawelder1 navseawelder1 is offline
Kentucky Wildcat Ranger
 
Join Date: Sep 2010
Posts: 27
Default Low rpm in park

Yesterday, I cleaned the MAF and the throttle body then cleaned the whole engine with simple green and turtle wax tire foam. Now my truck runs like a stripped ass ape but when I stop and put it in park, my rpm drops to 600, before it was 900 in park. Is this normal for the rpm to drop to 600? Thanks Mike
__________________
2003 Ford Ranger XLT Ext. Cab. No Mods
4.0 SOHC (E), Auto.
2WD
Reply With Quote
  #2  
Old 05-13-2011, 02:42 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Low rpm in park

Mine in park is around 600-700 range
__________________
2005 Edge

Reply With Quote
  #3  
Old 05-13-2011, 05:06 AM
navseawelder1 navseawelder1 is offline
Kentucky Wildcat Ranger
 
Join Date: Sep 2010
Posts: 27
Default Re: Low rpm in park

Quote:
Originally Posted by STL View Post
Mine in park is around 600-700 range
Thanks STL. That's 2 or 3 times I've ask a question and you helped me on it. Mike
__________________
2003 Ford Ranger XLT Ext. Cab. No Mods
4.0 SOHC (E), Auto.
2WD
Reply With Quote
  #4  
Old 05-13-2011, 05:27 PM
Botta Ranger Botta Ranger is offline
Ford Tough
 
Join Date: Jan 2011
Posts: 240
Default Re: Low rpm in park

Just reading about silicone contamination damaging O2 sensors. Any possible connection?
Reply With Quote
  #5  
Old 05-13-2011, 07:56 PM
navseawelder1 navseawelder1 is offline
Kentucky Wildcat Ranger
 
Join Date: Sep 2010
Posts: 27
Default Re: Low rpm in park

Not sure but I looked it up and yes it is possible. I will just have to wait a while and see.
__________________
2003 Ford Ranger XLT Ext. Cab. No Mods
4.0 SOHC (E), Auto.
2WD
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE Chargerondavins 3.0 Vulcan Tech 1 03-26-2011 04:54 PM
cutting out at low RPM Ranger Smokey 4-Cylinder Tech 4 12-03-2010 10:20 PM
95 4cyl ranger engine light and jerking in low RPM freakazeud Drivetrain Tech 2 08-30-2010 03:39 AM
Ranger Idling at low RPM? Northern_ranger 3.0 Vulcan Tech 7 04-27-2010 11:06 PM
4l v6 noise on low rpm only saskman 4.0 SOHC / 4.0 OHV Tech 5 10-05-2009 05:04 PM