Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-10-2011, 05:34 AM
00RANGERR 00RANGERR is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 5
Default Guys need your HELP

well got a 2000 ranger 4.0L... just last night on my way home it started stalling out at every light, and was idling well below 1000rpm.. any ideas? im thinking fuel filter but just wanna hear what the forum has to say and another problem is the 4x4, when i put it in the guage says im in 4high but only the back tires spin...now i dont know what thatmeans but its probably not good thx guys
Reply With Quote
  #2  
Old 05-10-2011, 05:45 AM
klinger86 klinger86 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 2,970
Default Re: Guys need your HELP

The idling problem sounds like the IAC needs cleaned. As far as the 4x4 problem I'm gonna guess and say maybe the hubs. Not sure maybe someone will chime in that knows more about 4x4s than I do.
Reply With Quote
  #3  
Old 05-10-2011, 10:43 AM
00RANGERR 00RANGERR is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 5
Default Re: Guys need your HELP

well cleaned IAC. still stalling out a sec after startup.. is bad gas a possiblitly?
__________________
FRF FTW!
Reply With Quote
  #4  
Old 05-10-2011, 10:47 AM
klinger86 klinger86 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 2,970
Default Re: Guys need your HELP

could be bad gas you could try putting some fresh gas and octane boost in and see if it will burn it out.... and change the fuel filter after you get rid of the bad gas.... if it wont burn it out the only other things to do is either drop the tank and syphone the gas out or disconnect the filler neck from under the truck and syphon that way....
Reply With Quote
  #5  
Old 05-10-2011, 10:50 AM
00RANGERR 00RANGERR is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 5
Default Re: Guys need your HELP

YEP..its gunna be an interesting afternoon
__________________
FRF FTW!
Reply With Quote
  #6  
Old 05-10-2011, 10:52 AM
klinger86 klinger86 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 2,970
Default Re: Guys need your HELP

instead of dropping the tank you could actually pull the bed off and do it that way.... probably a little easier than trying to wrestle the tank up and down....
Reply With Quote
  #7  
Old 05-10-2011, 10:58 AM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: Guys need your HELP

If your truck is completely stalling out, chances are the IAC is too far gone to clean. I've had this problem three times now. You can get a new IAC at Autozone for $45. 2 year warranty is pretty nice as well.

Does the idle kind of fluctuate up and down? Does it fluctuate with the A/C clutch when it cycles on/off? Does the truck hesitate when you get on the gas at stops?
Reply With Quote
  #8  
Old 05-10-2011, 10:59 AM
COFORDGUY COFORDGUY is offline
Like the Forums
 
Join Date: May 2011
Posts: 31
Default Re: Guys need your HELP

... on the 4x4 portion sounds like hub issue.. my dad had a 92 ranger and one of the hubs messed up and would not let that tire work properly then both sides in front stopped working.. had to replace the hubs
__________________
Mikey..
91 4x4 ext cab; 3" body lift: 4.0 OHV, 32X12.50 bfg's
will soon be named "bumblebee"
Reply With Quote
  #9  
Old 05-10-2011, 11:07 AM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: Guys need your HELP

I can't remember if 00 was included, but the 98-99 trucks had some pulse lock hub design that was prone to failing. I'm not familiar with it though, but there was a small discussion about it on FTE.

http://www.ford-trucks.com/forums/11...ub-system.html
Reply With Quote
  #10  
Old 05-10-2011, 11:16 AM
00RANGERR 00RANGERR is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 5
Default Re: Guys need your HELP

well it does its startup at 1500rpms or so then stalls out as quickly as it starts up.. like it should stop at 1000rpm after startup for idle, but it just bogs out

----------

yeah as far as the 4x4.. i think its the hubs too, but just wanna hear what FRF has too say like if theres any other underlying problems
__________________
FRF FTW!
Reply With Quote
  #11  
Old 05-10-2011, 11:54 AM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: Guys need your HELP

Hmm, Bogging down and dying at startup doesn't sound like an IAC to me. Have you checked your EGR valve if your truck is equipped with one?

You're most likely suffering vacuum problems with your 4x4, it's pretty common on both the Ranger and F150 of 98-00 vintage.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
What do you guys think luke Vehicle Snapshots 37 03-03-2011 05:23 PM
What do you guys think? MTman777 Lifted Suspension 0 02-09-2011 12:58 PM
sup guys rabid1 Introduce Yourself 6 10-21-2010 03:10 PM
Sup guys! one1 Introduce Yourself 10 01-13-2010 05:18 PM