Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-01-2011, 09:29 AM
MWDK MWDK is offline
Like the Forums
 
Join Date: Nov 2010
Posts: 41
Default High beams constantly on after bulb change

Hi everybody

I got my first Ranger a few days ago and I'm now changing some bulbs to get it to pass the safety inspection. Everything went well up until I got to the right side front marker light. I changed it with no problem, but now there is another problem: When ever the regular light is on on the right side, the high-beam bulb is on as well.

My truck is a 2002 Ranger FX4

Did I do anything wrong? Any ideas?

Happy may 1st,

Mathias

Last edited by MWDK; 05-01-2011 at 09:36 AM.
Reply With Quote
  #2  
Old 05-01-2011, 09:30 AM
Rango88 Rango88 is offline
N/A
 
Join Date: Jan 2011
Posts: 9,031
Default Re: High beams constantly on after bulb change

It would help if we had more info your truck, especially what year it is. Make a signature and include the info of your truck, it helps if you have question.
Reply With Quote
  #3  
Old 05-01-2011, 09:37 AM
MWDK MWDK is offline
Like the Forums
 
Join Date: Nov 2010
Posts: 41
Default Re: High beams constantly on after bulb change

Quote:
Originally Posted by Crowd88 View Post
It would help if we had more info your truck, especially what year it is. Make a signature and include the info of your truck, it helps if you have question.
Thanks, its done
Reply With Quote
  #4  
Old 05-01-2011, 01:58 PM
RWD HERO RWD HERO is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 38
Default Re: High beams constantly on after bulb change

Quote:
Originally Posted by MWDK View Post
Thanks, its done
What was wrong?
__________________
1996 Ford Ranger 2wd 2.3L, 407,000 miles of fury
2008 Ford F-150 4wd 4.6L
1987 Honda 250r quad
Reply With Quote
  #5  
Old 05-01-2011, 02:27 PM
MWDK MWDK is offline
Like the Forums
 
Join Date: Nov 2010
Posts: 41
Default Re: High beams constantly on after bulb change

Quote:
Originally Posted by RWD HERO View Post
What was wrong?
I edited my post with the year/model of my Ranger. The light is still not working right.
__________________
Ford Ranger FX4
2002, 4.0L V6
Reply With Quote
  #6  
Old 05-01-2011, 07:12 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: High beams constantly on after bulb change

It sounds like you have a floating ground. There should be ground wire securely bolted to the passenger side inner fender apron behind the washer reservoir near the cruise servo/module.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HID's stuck on high beams 125ranger Electrical Tech 5 05-24-2013 05:24 PM
Fog Lights stay off after turning off High Beams siooss Electrical Tech 1 12-14-2010 09:49 AM
new hids 6k +high beams druwevr Vehicle Videos 9 09-08-2010 12:18 PM
Fog Lights / High Beams Slobra232 Exterior Tech 34 05-26-2010 05:06 AM
Possible to change bulb socket(?) SaskRanger Exterior Tech 1 05-25-2010 07:04 AM