Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-27-2011, 10:00 AM
eagle 1 eagle 1 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2011
Posts: 17
Default Idle problem creating others

It seams as though I have an idle problem that is creating several others.
When I first start my truck the idle takes a short time to come down but does not do so far enough and the RPM's go up and down (slightly).
I can drop it into drive (auto trans.) quite smoothly, the problem is when I put it into reverse, it drops in quite hard and appears to actually rev higher. I have already had to install a rear end due to this.
If I drive for about a mile or more it will go into reverse fairly smooth and continue to do so until I park for a while.
I had it in an auto repair shop, of a friend, he could not determine the cause, but in order to save me his shop labor he suggested I change the "Mass air flow sensor" which I did and also the "PCV valve", still have the problem.
Any suggestions would be greatly appreciated
Thanks
Eagle 1
__________________

93 XLT extra cab 2x4 3.0 V6
Reply With Quote
  #2  
Old 04-27-2011, 10:30 AM
klinger86 klinger86 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 2,970
Default Re: Idle problem creating others

Have to tried cleaning the IAC?
Reply With Quote
  #3  
Old 04-27-2011, 10:38 AM
eagle 1 eagle 1 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2011
Posts: 17
Default Re: Idle problem creating others

After putting my problem on the site I checked the IAC valve and found a new one had been installed. sorry for not checking prior to inserting message
Eagle 1
__________________

93 XLT extra cab 2x4 3.0 V6
Reply With Quote
  #4  
Old 04-27-2011, 11:45 AM
terryduanemiller terryduanemiller is offline
www.shanewootenband.com
 
Join Date: Oct 2010
Posts: 1,896
Default Re: Idle problem creating others

Egr
__________________
MY BUILD THREAD
1999 MAZDA 2500SE, 2.5L 4-clanger, 5 speed, Green n slow. Rangers as daily drivers since 1988.
ASE Certified Mechanic, Builder of Show Destroying Protouring and Classic cars..
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough starting problem as well as high/low idle problem Ins4nity 4-Cylinder Tech 7 02-16-2011 06:10 AM
2001 idle problem 01smurfinator 4.0 SOHC / 4.0 OHV Tech 1 11-24-2010 07:48 PM
4.0 ranger hi idle problem foxracer01 4.0 SOHC / 4.0 OHV Tech 2 03-23-2010 12:24 AM
Idle Problem? Inv General Tech 0 03-15-2010 07:38 PM
Idle Problem softdots General Ford Ranger Discussion 4 11-14-2009 12:32 PM