Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 11-22-2010, 06:43 PM
chad05 chad05 is offline
Learning to use the forums
Join Date: Nov 2010
Posts: 1
Default Engine not turning over on first crank

I have a 2005 Reg cab Ranger Edge 3.0L with 98,000 miles. A few months ago the engine would not turn over on the first crank. Then on the second crank, it would turn over and start fine. Now it is usually taking a 3rd crank to start. After starting it runs fine. It is usually worse when it is cold but also can take a 3rd crank when the engine is warm. I have replaced the fuel filter thinking there might be a blockage with no improvement. I am also turing the igintion on for a few seconds before attempting the crank with no luck. What would be the next step to look at? Fuel pump? Could this be a crank sensor issue? Thanks
2005 Ranger Ranger Edge Reg Cab 3.0L V6 standard Trans 98,000 miles
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shaking really bad when turning SmokeyMcPot420 Drivetrain Tech 18 10-24-2013 02:09 PM
clicking when turning / in trails naturecakezzz Drivetrain Tech 13 11-18-2010 12:04 PM
Dying while turning OreEle 2.9 Liter Tech 2 10-25-2010 10:00 PM
4x4 Turning crackeyes Drivetrain Tech 5 07-19-2009 05:25 PM
Motor not turning over! john_boi 4-Cylinder Tech 4 06-16-2009 06:41 PM