Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-22-2009, 05:57 PM
smc1967 smc1967 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 7
Default Ford Ranger 99

Hi Guys, First time Post. I need some help locating a part number or part Name, so I can order.

I have to replace the lower rad hose fitting, the fittings that screws in to the thermostat housing; there is two fittings there, one runs to the down to the lower hose...... and I forget at the moment where the other one runs. But those fittings, the lower has a sensor on top,( one on each of them actually. )

well, one has sprug a leak and it is spraying a fine stream is spraying hot water all in my engine..

any ideas how I might find this. I asked the local auto parts store, and they didn't have it.. I guess I may have to goto the dealer??


thanks
S.McCool

Last edited by smc1967; 07-22-2009 at 05:59 PM.
Reply With Quote
  #2  
Old 07-22-2009, 06:58 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Does it go into the thermostat housing?
__________________
2005 Edge

Reply With Quote
  #3  
Old 07-22-2009, 07:38 PM
smc1967 smc1967 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 7
Default

Yes, this fitting connects to the housing.(there are two of these fittings that connect to the housing(thermastat) this fitting then connects to the a hose running down; connecting to the lower rad hose.
Reply With Quote
  #4  
Old 07-22-2009, 07:51 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Chilton's manual says if that fitting is corroded or pitted etc the thermostat housing will have to be replaced so you can just buy the fitting have to get whole housing

This is a 2.5 housing 84.79 RockAuto.com
__________________
2005 Edge

Reply With Quote
  #5  
Old 07-22-2009, 07:53 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Ford part number is F87Z8592AM 73.19 from tascafordparts.com
__________________
2005 Edge

Reply With Quote
  #6  
Old 07-22-2009, 07:55 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Thermostat Housing all 3 engine groups

I have bought from them and they are fast at shipping and very helpful

You may find it locally at auto store cheaper
__________________
2005 Edge

Reply With Quote
  #7  
Old 07-22-2009, 07:58 PM
smc1967 smc1967 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 7
Default

that looks nothing like my housing, or the part. mine sits square in front of the engine, the upper rad hose sit on top the engine then bends downwards about 5 in into the housing. the fittings are L shaped with a node on top - ╔ < looks like that sorta with a node on top, a heat sensor i think... I'm no pro...so i could be wrong

mine looks like they could be turned out and replaced.. and mine is leaking in the corner of the L , where it makes a turn a pin size hole has devloped. I cant see replaceing the whole houseing??

Last edited by smc1967; 07-22-2009 at 08:01 PM.
Reply With Quote
  #8  
Old 07-23-2009, 03:50 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Well U didn't say what engine u had so I was just guessing at which one it could possibly be

And that one looked like what u described
__________________
2005 Edge

Reply With Quote
  #9  
Old 07-23-2009, 05:44 AM
smc1967 smc1967 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 7
Default my Bad.

I ve been looking all over the net, and it seems i cant find what i have. I read about not being able to turn out the fittings.. that i have to replace the whole housing.
But it looks like I dont have a removable housing, I do Have Threads on the fittings and you can see the red sealant they used to screw them in.

I have a 3.01L I belive it said.. V6

also I have electric fans on the radiator... if that helps..


thank you for helping.

Last edited by smc1967; 07-23-2009 at 12:34 PM.
Reply With Quote
  #10  
Old 07-23-2009, 01:34 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Does it appear to be anything like this

Coolant Temperature Sensor

Coolant Temperature Sender


Also does which one better resembles your thermostat housing

1.


2.

__________________
2005 Edge

Reply With Quote
  #11  
Old 07-23-2009, 06:53 PM
smc1967 smc1967 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 7
Default Ill try to take a Picture.

I have a couple cameras, they dont take close ups well, but Ill try to get a shot. I should be able to get a picture good enought to be able to see what Im explaining.

thoese look like my sensors, but I need to recheck...

and that first pic of the housing cover is like mine. upper rad hose connects to it.
Reply With Quote
  #12  
Old 07-24-2009, 03:18 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Okay looked at my 4.0 and it is the same as yours your saying it is leaking from this area circled in red which is the bottom part of the thermostat hsg.







__________________
2005 Edge

Reply With Quote
  #13  
Old 07-24-2009, 03:34 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Also found this on ebay. This is the top and bottom the red arrows I added point to what you remove to replace the thermostat.

I have yet to find where you can buy the bottom part other that this ebay auction But it is for a 4.0 SOHC

__________________
2005 Edge

Reply With Quote
  #14  
Old 07-25-2009, 08:31 PM
smc1967 smc1967 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 7
Default Truck died Friday

lol, well my transmission went out Friday... ugh Reverse gave up, or jump out of link or something, drives in forward ok, but... at 165000 miles I am currently giving up on her. By the time I spent the money to fix it back up right , might as well get that GMC 0% for 60 months.
let me end by saying, thank you very much for the trouble you went thru!
however, none of those were like mine, and if you want me too, which I didn't get a chance to do; was take a picture of mine for show, Ill do it tomorrow if you want.. but, it looks like im getting a new 09 GMC 1500 for 16,700.. I guess that ok for a new truck...

and thanks again


Shawn
Reply With Quote
  #15  
Old 07-25-2009, 08:33 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Yes please post a picture you have me intrigued about this

I have been searching all over for what your talking about
__________________
2005 Edge

Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search