Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-18-2009, 08:40 PM
wigly1541 wigly1541 is offline
Learning to use the forums
 
Join Date: Jul 2009
Posts: 3
Default need help 95 ranger electrical

replaced fuel pump, was intermitant blowing the 30 amp big fuse in front of the fuel pump relay, have disconnected the plug to the fuel pump and back tracked the wires from tank back to engine compartment fuse block. Blows fuse immediately when switch ignition on. Plug on top of the fuel tank pump/guage disconnected and still blowing fuse.

Anyone? any ideas where the short may be? wires look great want suggestions before I slug the circut and look for smoke.
Reply With Quote
  #2  
Old 07-19-2009, 12:50 PM
pendelton pendelton is offline
Like the Forums
 
Join Date: May 2009
Posts: 35
Default

i'll bet the short is in the box that holds the relays.mine has a short as well but it does'nt blow the fuse.it just flat stops working.the wires inside that box are very close together it would'nt take much for em' to touch.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problem MrPlumber Electrical Tech 16 12-07-2016 02:56 PM
Electrical Grimlins STL Electrical Tech 2 07-08-2009 06:07 PM
Electrical problem! Patch97236 Electrical Tech 1 06-26-2009 02:12 PM
Radio and 4x4 electrical problem DQuinn Electrical Tech 0 06-04-2009 10:30 AM