Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-21-2018, 11:09 PM
bo bo head bo bo head is offline
Learning to use the forums
 
Join Date: Jul 2018
Posts: 1
Default Trans problem ?

My 1999 4x4 Ranger seldom gives me any problems. Today all of a sudden there was loud clunking sound when slowing down or speeding up. Sounded like the drive shaft. The speedometer stopped working and the overdrive light was blinking. I was going to drive home thinking something was going to go out any second. I stopped at a gas station and went in the store turning off the engine. When I came back to the truck, it acted like nothing happened and drove normal??? I always use the overdrive button to slow down into the lower gear. Don't think this has anything to do with it. This is a very weird problem in my long history of truck and car ownership. I am an outboard motor mechanic so know a few things.

Last edited by bo bo head; 07-21-2018 at 11:12 PM.
Reply With Quote
  #2  
Old 07-22-2018, 03:57 AM
Undrstm8ed Undrstm8ed is offline
Habenae Est Dominatus
 
Join Date: Apr 2013
Posts: 1,846
Default Re: Trans problem ?

There should be a soft code in the ECU to pull... Start there.
__________________
_______________________

My Build Pg. Threads
+ 93' Ranger Overlanding Build
+ 94' Ranger Bed Overlanding Trailer Build
+ 12 North Industries ~ I Support
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic Trans problem? zztopp Drivetrain Tech 2 04-13-2015 01:21 PM
Trans problem. 2004ranger4x4 Drivetrain Tech 6 09-10-2013 09:54 AM
Trans. Problem LTFox 3.0 Vulcan Tech 1 04-02-2013 02:38 PM
trans problem dangerranger01NJ Drivetrain Tech 0 09-29-2012 06:28 AM
trans problem please help texperry Drivetrain Tech 0 03-03-2012 11:41 AM