Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-26-2018, 09:07 AM
jnswhit@hotmail.com jnswhit@hotmail.com is offline
Learning to use the forums
 
Join Date: Mar 2018
Posts: 2
Unhappy Speed Sensor???

Driving down the road and suddenly not shifting into 2nd gear engine revving and then slam into gear, The ABS light is on and the O/D lamp is flashing. Then I noticed the speedometer was not moving. Checked the ABS sensor in the rear end and it measures zero ohms. So does the transmission use this sensor to determine vehicle speed? Does this sound like the problem? All the problems? Any ideas
__________________
1999 Ford Ranger 4X2 XLT 3.0L
Reply With Quote
  #2  
Old 03-26-2018, 09:44 AM
RoberticusMaximus RoberticusMaximus is offline
<<< Husky the High Dog!
 
Join Date: Jan 2012
Posts: 7,120
Default Re: Speed Sensor???

yes the sensor on top of the rear diff is the VSS (vehicle speed sensor) and the computer uses it for RABS, the Speedo/Odo, and i'm sure it uses the speed reading for shifting as well.
...anyway, i have a manual truck. that sensor went bad on me - both the speedo went out and the ABS light was on at the same time. naturally i didn't have any issues with shift points like you tho.

just curious, did you find a test procedure or something that referenced a particular ohm value for that sensor? that's some pretty neat info i'd kinda like to know myself!
Reply With Quote
  #3  
Old 03-26-2018, 10:49 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 921
Default Re: Speed Sensor???

Quote:
Originally Posted by RoberticusMaximus View Post
just curious, did you find a test procedure or something that referenced a particular ohm value for that sensor? that's some pretty neat info i'd kinda like to know myself!
The factory 99 Ranger Wiring Manual shows 1400 ohms for the rear axle sensor.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #4  
Old 03-27-2018, 06:29 AM
RoberticusMaximus RoberticusMaximus is offline
<<< Husky the High Dog!
 
Join Date: Jan 2012
Posts: 7,120
Default Re: Speed Sensor???

bad to the bone! thanks!
Reply With Quote
  #5  
Old 03-27-2018, 08:00 AM
NewShockerGuy NewShockerGuy is offline
2001 XLT
 
Join Date: Oct 2011
Posts: 1,214
Arrow Re: Speed Sensor???

Quote:
Originally Posted by rwenzing View Post
The factory 99 Ranger Wiring Manual shows 1400 ohms for the rear axle sensor.
You by chance wouldn't happen to know the rear axle sensor for a 2001 ranger? I ask and not to thread hijack because my ABS light came on intermittently and when I test the rear sensor by spinning the rear wheels it reads zero on my live graph and then when I test resistance it's only 653 which seems low...

Thanks,
-Nigel
__________________
_____

2001 Ranger XLT 2.3L Auto: Bunch of misc mods.
Little lift: 4" Spindle Lift w/ 2" shackles and 2" oem blocks.OEM Ranger Sport Wheels: Tires=245x75x16

~NSG~
Reply With Quote
  #6  
Old 03-27-2018, 08:51 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 921
Default Re: Speed Sensor???

Quote:
Originally Posted by NewShockerGuy View Post
You by chance wouldn't happen to know the rear axle sensor for a 2001 ranger?
The 2001 Wiring Manual does not call out the resistance. However, Motorcraft lists the same rear axle sensor for 1990~2009 Ranger. So, IF that's right AND IF the older Wiring Manuals/EVTM's are correct, then your 2001 should also be around 1400 ohms.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #7  
Old 03-28-2018, 08:17 AM
NewShockerGuy NewShockerGuy is offline
2001 XLT
 
Join Date: Oct 2011
Posts: 1,214
Default Re: Speed Sensor???

hmm, welp that helps! It's funny I replaced a Raybestos sensor that I never had a problem with because it was old and the connector didn't fit right to an OEM ford one. Only to find out that the Ford one is not working properly as per when I check the ohms...go figure. Should have a new sensor in a day or two, hopefully that one isn't defective.

Appreciate the info!

-Nigel
__________________
_____

2001 Ranger XLT 2.3L Auto: Bunch of misc mods.
Little lift: 4" Spindle Lift w/ 2" shackles and 2" oem blocks.OEM Ranger Sport Wheels: Tires=245x75x16

~NSG~
Reply With Quote
  #8  
Old 02-11-2019, 12:49 AM
Nctitan7 Nctitan7 is offline
Learning to use the forums
 
Join Date: Feb 2019
Posts: 1
Default Re: Speed Sensor???

I know this thread is about a year old but I’m having an issue with my 1992 ford ranger 4.0 all stock automatic transmission. Speedo went to zero while on the hwy. so when I got home I pulled the VSS and noticed the speedo gears was missing about 4 teeth on it. Got the new gear put it on and bought a brand new VSS. Speedo works but bounces really bad (didn’t used to do that at all). And is reading 15 mph off. Same color on the Speedo gear and same # of teeth on the gear. I’m lost now and don’t want to it needs to be fixed.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Sensor S7S Drivetrain Tech 2 03-20-2016 10:01 AM
4.0L Coolant Temp Sensor & Transmission Speed Sensor apz*jr 4.0 SOHC / 4.0 OHV Tech 2 04-03-2015 05:36 AM
ABS Light - Replaced Diff. Speed Sensor & MC Sensor GlennFord General Tech 27 08-04-2014 05:22 PM
speed sensor kyranger98 Drivetrain Tech 1 12-09-2013 09:55 AM
Possible Speed Sensor??? What do you think? Stringer Drivetrain Tech 1 10-08-2010 11:23 AM