Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-06-2017, 07:07 AM
jksweld jksweld is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 6
Default 02 ranger engine swap no start, no fuel

hey guys,

Have a 02 ranger 4x4 4.0 auto xlt FX4. Blowed up the 4.0 and bought another truck for donor. Donor truck is 00 ranger 4x4 3.0 auto. Switched out the blowed 4.0 motor and trans and computer, with the 3.0 motor trans and computer. Tried to start and nothing!! Have power when key is in on position but go to start and nothing. Don't think the fuel pump is kicking on or any relays in power distribution box and starter doesn't crank. Seem to have all other power, windows, dash lights, interior lights, headlights, and cig plug.

Any help is appreciated
Thanks in advance
Reply With Quote
  #2  
Old 11-06-2017, 08:12 AM
JAMMANICA JAMMANICA is offline
Craigslist is awesome
 
Join Date: Jun 2016
Posts: 536
Default Re: 02 ranger engine swap no start, no fuel

Did you use the ECU from the 3.0 donor.

Welcome to FRF

----------

Upon reading a little, you have a type E pats in the 02 and a type B from the 00. The speedo isn't going to work the signal comes from the tranny in the 02 and from the rear axle in the 00.

I'm sure you can get it to work eventually but man you took a hard road I would have found a 4.0 from a 01 or newer would have been a virtual drop in.
__________________
00 XLT 4WD XCSB 4.0 my new baby
00 XLT 2WD RCSB 5.0 swap in progress.
98 XLT 4WD XCSB 4.0 dead
99 EXPO donor motor for dead one and parts for the others.
Ford Enthusiast
Reply With Quote
  #3  
Old 11-06-2017, 09:49 AM
jksweld jksweld is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 6
Default Re: 02 ranger engine swap no start, no fuel

I used the one that is held in with two 10mm nuts in the firewall

EDIT: after research yes it was the ECU that I did change, I always called it the PCM, sorry

Thanks for the welcome

----------

Can I disable the PATS and get it running?

Not concerned with the speedo at this point, as long as it doesn't effect anything else running wise. Need to get truck running asap as its my daily driver and I'm having to borrow a vehicle to get to work from my parents

Last edited by jksweld; 11-06-2017 at 09:43 AM.
Reply With Quote
  #4  
Old 11-06-2017, 12:27 PM
Undrstm8ed Undrstm8ed is offline
Habenae Est Dominatus
 
Join Date: Apr 2013
Posts: 1,247
Default Re: 02 ranger engine swap no start, no fuel

You have a wiring issue. Something in your harness isnt powering up either a relay or group of relays so a portion of the wiring system that is likely to be powered up with KO is dead.

You need to find or get the digital FSM for your truck and the Donor truck and literally scope out both wiring systems from the battery to the ECU and the ECU to the engine in comparison. You may be lucky and just have a blown fuse or a wire that needs to be de-pinned and re-pinned into another part of the plug.. Worse case a total rewire from the body to engine harness.

Other thing you may want to dbl check to make sure that as you did the swap, perhaps in an absence of mind you missed a ground terminal ring that needs to be bolted down.. It happens. But you are going to have to seriously get out your DVOM and test the pin-out the wiring harness like they test when they build them.

good luck
__________________
"Your right, there is no "I" in Team But there sure is in Independence, Individuality, and Integrity.."

- 93' Ranger, Overland Build thread http://www.fordrangerforum.com/proje...ing-build.html
Reply With Quote
  #5  
Old 11-09-2017, 05:35 PM
jksweld jksweld is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 6
Default Re: 02 ranger engine swap no start, no fuel

Small update....

Removed the harness from the donor truck, distribution box, two square plugs going thru firewall under steering wheel, all the way around the front end to blower and such on pass side. Now my question is, if I would take out my dist box, square engine plug and two big plugs going thru firewall, roll them up enough to hook up the donor harness would I be able to check if truck will start??
Reply With Quote
  #6  
Old 11-09-2017, 05:59 PM
JAMMANICA JAMMANICA is offline
Craigslist is awesome
 
Join Date: Jun 2016
Posts: 536
Default Re: 02 ranger engine swap no start, no fuel

I don't think it would be dangerous I would definitely do it before installing everything in place just in case it doesn't work for some reason.

I have never personally attempted what you are doing. But your last post is something I would do in your situation.
__________________
00 XLT 4WD XCSB 4.0 my new baby
00 XLT 2WD RCSB 5.0 swap in progress.
98 XLT 4WD XCSB 4.0 dead
99 EXPO donor motor for dead one and parts for the others.
Ford Enthusiast
Reply With Quote
  #7  
Old 11-09-2017, 06:52 PM
jksweld jksweld is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 6
Default Re: 02 ranger engine swap no start, no fuel

10-4, that's the way I looked at it as well. Thank you sir!
Reply With Quote
  #8  
Old 11-09-2017, 11:38 PM
jksweld jksweld is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 6
Default Re: 02 ranger engine swap no start, no fuel

Well that didn't work, blew the #24 fuse inside cab. Starter interrupt relay, the good news I believe I had a relay kicking in that I didn't have with the 4.0 body harness
Reply With Quote
  #9  
Old 11-14-2017, 08:39 PM
jksweld jksweld is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 6
Default Re: 02 ranger engine swap no start, no fuel

Finally got it to start. I made the 4.0 body harness match the 3.0 engine harness at the square plug on top of the engine. Got the fuel pump relay to kick in, but still no starter. I then started tracing down 5 wires that were in the 4.0 harness and not the 3.0. As best I could tell with schematics I found on the web, 3 we're for the pats, one starter relay control and one ground. So, I then got pcm pin location from the 4.0 and removed the 5 wires from 4.0 pcm to square engine harness plug, remove same 5 wires from square plug on body side and plugged all 5 together by color, still just fuel pump. Switched out the 3.0 ecu with the old 4.0 edu and it fired right up!!!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.0 engine swap fuel problem Nikgt500 3.0 Vulcan Tech 0 10-08-2016 02:19 PM
Flex Fuel ro Non Flex Fuel Engine Swap Terrywmj 3.0 Vulcan Tech 1 02-04-2013 07:34 AM
Engine Wont Start After Injector Swap. Answer needed ASAP. MilesRangerXLT 3.0 Vulcan Tech 2 01-16-2012 05:50 PM
Engine turns wont start - no fuel - no spark - pcm not powered! acheesebagel 4-Cylinder Tech 8 09-18-2011 12:31 PM
Fuel injected 302 engine swap Robert Carlson 8-Cylinder Tech 5 04-25-2010 08:00 PM