Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-26-2008, 11:55 PM
smiles
Guest
 
Posts: n/a
Default what would cause my 88 ranger pickup to take long to warm up before running right.?

my pickup has to idle for awhile before it runs right
Reply With Quote
  #2  
Old 11-26-2008, 11:57 PM
Jeremy G
Guest
 
Posts: n/a
Default

It may need a tune up. New plugs, wires, cap, and rotor may make a difference.
Reply With Quote
  #3  
Old 11-26-2008, 11:58 PM
bobweb
Guest
 
Posts: n/a
Default

One possibility: Engine Coolant Temperature (ECT) sensor bad. Check it similarly to the ECT test procedures below:

http://www.autozone.com/az/cds/en_us/0900823d/80/04/f5/ac/0900823d8004f5ac/repairInfoPages.htm
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
93 ranger build... lots to do over a long time haha beaujt Project Logs 7 11-26-2009 11:02 PM
new yorker long time ranger owner tonyarf Introduce Yourself 1 05-08-2009 02:43 PM
Idle problem when weather is warm JBB General Ford Ranger Discussion 1 05-04-2009 10:17 PM
Long time ranger owner. Airtruksrus Introduce Yourself 6 05-03-2009 12:40 PM
-42 this morning. while driving ford ranger. engine light came on and no warm spole33 General Ford Ranger Discussion 4 01-15-2009 11:54 AM