Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-21-2010, 10:11 PM
tcmills3 tcmills3 is offline
Join Date: Feb 2010
Posts: 243
Default Reverse Fogs

Well I put some aftermarket 20 buck foglights under my bumper wired to my reverse lights. Last week howver one filled with water after heavy rain. Now they wont turn on. I do not know why this is. Could it be a fuse?
1999 4x4 xlt
4.0 v6
3inch PA body lift
2 inch torsion bar crank
1.5 inch rear shackles
32x11.50 BF Goodrich KM2 mud terrians
15x8 Cragar v5s
Dee Zee brush guard and taillight guards
Reply With Quote
Old 06-30-2010, 09:13 PM
TerrenceStuart TerrenceStuart is offline
Join Date: Nov 2009
Posts: 14,843
Default Re: Reverse Fogs

there $20. one filled with water. Now they don't work.
yes, it's a fuse. Water and bulbs = blown fuse. and , or a busted bulb.
2007 EXPLORER 4.0 4X4
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
blacked out my heads,fogs, and ford emblem CJG Exterior Tech 24 01-17-2011 09:58 AM
Want to Buy: 04-05 textured valance with fogs sullys_ranger Exterior Parts 4 04-11-2010 10:43 PM
Factory Fogs Not Working DarkEdge05 Electrical Tech 5 03-08-2010 08:09 PM
HID & Fogs Install Complete LoOk! CoOl PiC! uajosh Exterior Tech 11 03-03-2010 08:01 PM
01/03 EDGE W FOGS to fit 99 Dcrymes99ranger Exterior Tech 9 03-01-2010 07:08 AM