Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-24-2011, 06:22 PM
JoshuaC JoshuaC is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Red face New cat, now CEL on

I just bought a 1996 ranger 2.3L with 66K miles. I failed inspection for an exaust leak so I crawled under there and found the catalytic convertor had a huge hole in the top. I ordered a cat assembly (covertor with pipes and flanges welded on) and tried to change it but couldn't get the manifold flange bolts off. So I took it to the corner garage and they did the work for me. A couple days later, my check engine light comes on and my fuel economy is worse by 4 mpg. What gives? I hate state inspections. The truck ran better before I sunk $250 into it.
__________________
1996 2WD 4cyl Ranger
Gas Saver
Reply With Quote
  #2  
Old 03-24-2011, 07:39 PM
matt224 matt224 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 591
Default Re: New cat, now CEL on

Probably a faulty 02 sensor. Did this garage replace your 02's? or even plug them back in?
__________________
2006 Fx4 Level 2 with a 5spd, Superlifted on 33's.
Reply With Quote
  #3  
Old 03-25-2011, 03:54 AM
JoshuaC JoshuaC is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: New cat, now CEL on

That was the first thing I looked at. The old O2 sensors are in the new pipe (before and after cat). I think I will just replace those two sensors and give the computer a little time to adjust. It seems like the CEL would have been on before though, with the old cat that had a hole in it and bad O2 sensors.

What about the size of the convertor? The new one is about 1/3 the size of the old one. When I received the cat from fedex, I was suprised at how much smaller it was but I figured the only problem would be that it colgs up quicker than an OEM size unit. Is this right or am I way off in thinking that?
__________________
1996 2WD 4cyl Ranger
Gas Saver

Last edited by JoshuaC; 03-25-2011 at 03:56 AM.
Reply With Quote
  #4  
Old 03-25-2011, 08:57 AM
matt224 matt224 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 591
Default Re: New cat, now CEL on

was the cat assembly a Ford OEM part? It might just be a higher flow unit if its aftermarket.

If your CEL light is on now and you are experiencing power problems/economy problems, it could be the cause of your PCM going into an open loop fail safe mode. Some times if the computer detects a problem, the computer will make the engine run rich so the car will at least run and get you places. You should bring the car to Autozone or some where and have them scan the codes your computer is throwing. You have a 1996 which should mean you have the current OBDII
__________________
2006 Fx4 Level 2 with a 5spd, Superlifted on 33's.
Reply With Quote
  #5  
Old 03-25-2011, 09:03 AM
99offroadrngr 99offroadrngr is offline
Banned
 
Join Date: Sep 2009
Posts: 945
Default Re: New cat, now CEL on

that sucks. I'm guessing its the sensors. Fuck mass. I hate this state. lol
Reply With Quote
  #6  
Old 03-25-2011, 03:03 PM
JoshuaC JoshuaC is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: New cat, now CEL on

I have noticed the truck running a little better the last couple of days. It doesn't idle as high all of the time like it was immediately after the new cat was installed. I'm thinking the computer is adjusting to the new exhaust system now that it has a bit of history (it's been about a week and a half ~210miles) but the CEL is still on. I'll have the codes scanned and go from there. Thanks for the help--I'll update the post when I get more info at Autozone.

@99offroadrngr Everything in Mass is illegal. It drives me crazy!!
__________________
1996 2WD 4cyl Ranger
Gas Saver
Reply With Quote
  #7  
Old 03-25-2011, 09:08 PM
TheStig TheStig is offline
My truck snorts.
 
Join Date: Sep 2009
Posts: 820
Default Re: New cat, now CEL on

__________________
1996 XLT 2.3T "White Lightning" 5/7 dropped, Turbo street toy
2006 FX4 Off Road, DD, work in progress
1985 XLT 2.8L 4x4 "The Black Pearl" (retired but still around)
1987 XL 2.3L 2wd R.I.P.
Quote:
Originally Posted by RangerAllie View Post
I love me some Stig
Reply With Quote
  #8  
Old 03-27-2011, 07:30 AM
JoshuaC JoshuaC is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: New cat, now CEL on

I had Autozone scan the computer for codes yesterday.
P0141--Heater condition (heated oxygen sensor, Bank 1 Sensor 2).
"The powertrain control module monitors the oxygen sensor heater. The computer has recognized a failure in this circuit"
Probable cause:
1. Faulty HO2S12 (Bank 1 Sensor 2)
2. Poor connection at oxygen sensor
3. Check circuit - fuse
This morning I crawled back under the truck and made sure the sensor wires were completely plugged in--they were. I checked the condition of the sensors--the downstream sensor case was loose and could be moved by hand. My guess is the mechanic broke it while removing it from the old pipe or tossed the old pipe on the ground with the sensors still mounted. I'll pick up a new sensor from Autozone today.
__________________
1996 2WD 4cyl Ranger
Gas Saver
Reply With Quote
  #9  
Old 03-27-2011, 04:24 PM
JoshuaC JoshuaC is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: New cat, now CEL on

I replaced the downstream O2 sensor today and took my wife for a long drive up the coast and back. CEL turned off after about 75 miles.
Thanks for your help guys!
__________________
1996 2WD 4cyl Ranger
Gas Saver
Reply With Quote
  #10  
Old 03-27-2011, 06:42 PM
matt224 matt224 is offline
Ford Ranger Driver
 
Join Date: Jan 2011
Posts: 591
Default Re: New cat, now CEL on

glad you got it figured out man!
__________________
2006 Fx4 Level 2 with a 5spd, Superlifted on 33's.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
NewBie here, with CEL... :-( techranger 4-Cylinder Tech 14 03-24-2011 06:46 PM
CEL randomly on? snipes040 3.0 Vulcan Tech 2 03-24-2011 07:36 AM
CEL Puzzle Moedad 4.0 SOHC / 4.0 OHV Tech 1 02-19-2011 06:55 PM
Cel mehdi1993 3.0 Vulcan Tech 2 11-12-2010 09:46 AM
CEL keeps coming on 1freaky1 4.0 SOHC / 4.0 OHV Tech 26 03-08-2010 10:29 AM