Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-19-2010, 09:03 PM
expertbasser expertbasser is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 19
Default EXAUST/idle problem! HELP!!!!!!!!!!!!!!!!!!

After being helped on here by sooooo many Ranger owners, I now have a NEW problem:

After replacing a few major components (EGR valve, both upstream O2 sensors, MAF, that funky egr control box that I cant remember what it is called, & some other stuff from my previous problem, I now have a NEW one!), I now have an erratic, LOW idle SOMETIMES! It dont do it all the time, & always at different times. You can start the engine, it'll come up to 1100 rpm, then drop all the way down to about 100 rpm, then jump back up to 1100, then back down, over & over & eventually die. Turning the ign off, then restarting has no effect, BUT you can put it in drive, hold a little bit of pedal on it for a few seconds, & USUALLY, it will straighten out & do fine, for a while. Changed gas stations a few times, using NO ETHANOL GAS!

WHEN this happens, I get a strong smell of cat. converter from the exaust. NO CEL coming on either.

HELP & Thanks in advance!

Oh, almost forgot:
2001 Ranger, 4.0L SOHC, automatic, 4WD, stepside.

Greg Johnson.
__________________
2001 Ford Ranger (4 door)
4.0L SOHC Stepside
COLD Air intake
Extang VINYL Tonneau with WING
31X10.50X16 all around
2001 Ranger HARLEY DAVIDSON 100th Anniversary Edition! ALSO: Check out MY pictures!!!
Reply With Quote
  #2  
Old 11-19-2010, 09:30 PM
terryduanemiller terryduanemiller is offline
www.shanewootenband.com
 
Join Date: Oct 2010
Posts: 1,896
Default Re: EXAUST/idle problem! HELP!!!!!!!!!!!!!!!!!!

I think I might have you covered, mine did simular, take a BB (yes like BB gun) put inside of EGR vaccum line, push back on.. the BB is to large to fall into EGR and to large to get sucked into engine, thus blockin EGR.. ford lovers have been doin this trick for years
__________________
MY BUILD THREAD
1999 MAZDA 2500SE, 2.5L 4-clanger, 5 speed, Green n slow. Rangers as daily drivers since 1988.
ASE Certified Mechanic, Builder of Show Destroying Protouring and Classic cars..
Reply With Quote
  #3  
Old 11-21-2010, 09:39 PM
expertbasser expertbasser is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 19
Default Re: EXAUST/idle problem! HELP!!!!!!!!!!!!!!!!!!

TRIED the bb trick to no avail. Found out Friday, the EGR solenoid was NOT making enough vacuum. Replaced & now has vac. PROBLEM STILL THERE!

Ran the scan on it today, code is: T.P.S. not comm. with MAF meter. MAF is NEW, NOT reman, replacing the TPS Monday.
__________________
2001 Ford Ranger (4 door)
4.0L SOHC Stepside
COLD Air intake
Extang VINYL Tonneau with WING
31X10.50X16 all around
2001 Ranger HARLEY DAVIDSON 100th Anniversary Edition! ALSO: Check out MY pictures!!!
Reply With Quote
  #4  
Old 11-23-2010, 05:58 AM
expertbasser expertbasser is offline
Liking the Ford Ranger Forum
 
Join Date: Sep 2010
Posts: 19
Default Re: EXAUST/idle problem! HELP!!!!!!!!!!!!!!!!!!

UPDATE 11-23-2010!

PROBLEM COMPLETELY SOLVED!

TP sensor was going bad. Was also original with 67,000 miles. Installed a NEW Beck T.P. sensor, plug & play. Even my spark knock is GONE!!!

__________________
2001 Ford Ranger (4 door)
4.0L SOHC Stepside
COLD Air intake
Extang VINYL Tonneau with WING
31X10.50X16 all around
2001 Ranger HARLEY DAVIDSON 100th Anniversary Edition! ALSO: Check out MY pictures!!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle problem (yes I have searched) 03b2300 4-Cylinder Tech 8 10-26-2010 08:31 PM
Idle and driving problem Pantech 4.0 SOHC / 4.0 OHV Tech 2 09-12-2010 09:14 PM
High Idle Problem with AC on miljeep66 4-Cylinder Tech 6 06-26-2010 02:19 PM
Idle Problem? Inv General Tech 0 03-15-2010 07:38 PM
Idle Problem softdots General Ford Ranger Discussion 4 11-14-2009 12:32 PM