Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-07-2013, 07:28 AM
Scrach Scrach is offline
Learning to use the forums
 
Join Date: Oct 2011
Posts: 4
Default rear diff abs sensor

1999 Ranger 2.5L 4cyl 2WD... plain jane.

The GoPoint app on my phone gave me a code on the rear diff sensor, so I just bought a new one for a hopefully cheap, easy fix. Standard brand, about $15... Installed it, hopped in, ran down the road and the truck wouldn't shift out of 1st (while in D ) and the speedo wasn't working. Went back to the garage, reset the codes with my phone app, same results. Tried again by disconnecting the battery, same results. Bought another new part ( Dorman brand, I think ), same routine, same results. THe big kicker is after each new part, I reinstalled the original sensor ( a Ford part ) and everything worked fine ( but still with a code and check engine light resulting ).

My next idea is to get a new,genuine Ford part, but it just seems wrong that two new parts wouldn't solve the problem.

Thoughts, ideas and solutions much appreciated.
Reply With Quote
Reply

Tags
abs sensor, rear diff, speedo

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Sensor rfs1ham General Tech 1 11-23-2012 06:54 PM
Changed the rear diff oil and new diff cover Clinton Vehicle Snapshots 23 07-09-2011 09:16 AM
Rear abs sensor EMB1230 Electrical Tech 1 02-03-2011 05:20 PM
4x4 Front diff = rear diff? wintermute Drivetrain Tech 9 10-24-2010 08:01 AM
ABS Sensor RallyTruck Wheels and Tires 0 12-15-2009 08:24 PM