Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-17-2013, 11:14 AM
Hatcher Hatcher is offline
Learning to use the forums
 
Join Date: Mar 2013
Posts: 5
Default 07 Ranger random PAtS lock out!

I have an 07 2.3L standard Ranger and the PATS has been causing random no starts for months. I have been to Ford 3 times and spent $500. They have not found the problem but have suggested replacing the IC 'may' fix it to the tune of $1000. They are not getting any more of my money! Their other suggestion was to sell it and make it someone else's problem?

The first visit they said they replaced a faulty relay. Second visit they said they got a code that had a TSB and they did an upgrade to the computer. 3rd time they charged me 2 hrs diagnostic, said there were no codes and wires are all attached, and threw their hands in the air! NEVER going back!

This is making me crazy. Definitely seems to happen more when its raining, which we get alot of here on the coast. Dash lights flashing, mileage flashing off, and needles moving up and down also, but not all the time (like dry days). Gauges started acting up last winter, didn't do it all summer, then started again this fall and then the PATS started acting up. Lock light flashes on dash and engine won't turn over.
Reply With Quote
  #2  
Old 03-17-2013, 11:15 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,938
Send a message via AIM to djfllmn
Default Re: 07 Ranger random PAtS lock out!

sounds like a bad key to me
__________________
2019 Ranger Screw Lariat 501A

Past:18 F150 2.7, 16 F150 5.0, 14 F150 5.0, 07 F150 5.4, 03 Ranger 4.0

Master Certified Ford Parts / Warranty Admin
Reply With Quote
  #3  
Old 03-27-2013, 06:46 PM
Hatcher Hatcher is offline
Learning to use the forums
 
Join Date: Mar 2013
Posts: 5
Default Re: 07 Ranger random PAtS lock out!

Yes, I have searched and googled. Well, I left my truck with my mechanic for the last week so he could look at it between appointments. Here is what he found. The ECM sits in the top left of the engine compartment, directly under a vent without any protection whatsoever from the rain. He got a diagram from Ford, and it shows there is supposed to be a box protecting the ECM from the weather. I bought this truck brand new from Ford, and this box has never been in there. There is some corrosion on the outside of the ECM, so is possible water getting in there has caused my electrical issues! I called a Ford dealer and told him what we found. He said in the mid 90's many Windstars had their transmissions burn out because of shorting from water getting into the ECM, which was why they started enclosing the ECM's in these protecting boxes. Hopefully getting a box for it will fix my issue. Soo frustrating! So much inconvenience and aggravation, not to mention expense, over the last several months trying to find the cause of my issues!! Now to call Ford Canada and rip a strip off them!
Reply With Quote
Reply

Tags
anti-theft, dash, no-start, pats

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
(Canada) Where did you get your Pop&Lock Tailgate Lock? ricochet Canadian Region 8 02-03-2013 09:26 AM
PATS Control Module Location on '99 Ranger? Guest Electrical Tech 2 04-28-2011 10:48 PM
Can thieves bypass PATS system on a Ranger.... 2010 General Ford Ranger Discussion 13 01-26-2011 11:52 PM
Service help needed with Pop lock tailgate lock installation gomez66 Exterior Tech 1 09-22-2010 09:45 AM
Pats / Non pats keys 2005 Edge TheJellyman Electrical Tech 3 10-18-2009 05:47 PM