Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > Electrical Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-21-2010, 12:41 PM
Ford Truck Driver
 
Join Date: Dec 2009
Posts: 99
Default Cruise control not working

My cruise control has not worked for about a year now, and since I've only gotten a job recently, have I thought about fixing it. Here are the specs for my Ranger:

Year: 2001
Model: Supercab XLT
Engine: 4.0L V6
Trans: Automatic, 4wd


Problem: When I turn my cruise "on" and hit 'set', the 'speed control' indicator will flash on the dash for a brief second, then go off, with the cruise not being set or even working. It will only 'flash' once, until I turn it off and back on again, will it flash again. Any thoughts you might have or suggestions are greatly appreciated! Thanks!

Gerrit
__________________
2001 Ford Ranger XLT Stepside: Stock
Reply With Quote
  #2  
Old 02-21-2010, 01:16 PM
STL STL is offline
...............
 
Join Date: May 2009
Posts: 22,159
Default

Check the cable that goes to the throttle on the engine. Also check the fuses
__________________
2005 Edge

Reply With Quote
  #3  
Old 02-22-2010, 06:58 PM
Ford Truck Driver
 
Join Date: Dec 2009
Posts: 99
Default

After some word of mouth from a few of my other car buddies, they mentioned a recall on Ford truck's and cruise controls, so I went to my local dealer to see what it was about. The main issue of the recall is the brake pressure switch mounted just in front of the resevoir on the master cylinder. It will leak brake fluid, causing the switch to short out. Unfortunately, my truck was not covered under the recall for whatever reason, but for $18.55 and 15 min. in the driveway, its working just fine again.
__________________
2001 Ford Ranger XLT Stepside: Stock
Reply With Quote
  #4  
Old 04-26-2010, 05:37 AM
Learning to use the forums
 
Join Date: Jan 2010
Posts: 2
Default Re: Cruise control not working

Something else to check- and don't think this is crazy- but my cruise control quit functioning right before I took it in for inspection. They rear brake light was burnt out so it was replaced and- no kidding- the cruise control started workin again.
94, 4.0, 2WD, XTRA cab
Reply With Quote
  #5  
Old 06-03-2012, 09:37 AM
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 19
Default Re: Cruise control not working

My ranger had the same problem the switch will fix it $19.00 will do the trick.
Reply With Quote
  #6  
Old 07-21-2012, 12:53 PM
Learning to use the forums
 
Join Date: May 2012
Posts: 7
Default Re: Cruise control not working

NOTES: These tests are only available on vehicles with processor controlled cruise control systems (Taurus/Sable, some Lincoln, Crown Victoria, Grand Marquis, Thunderbird and Cougar models). These tests will not test the speed sensor. Usually there will be a regular EEC code if it is bad. You might also want to look at the link for regular cruise above. It has a page that explains some of how the cruise works. It works pretty much the same on the processor controlled systems, but the EEC processor takes the place of the cruise amplifier.

Key On Engine Off (KOEO) test:
1. Hook a tester up to the EEC IV connector, but leave the trigger unplugged (or test switch off on some testers). Try to position the tester or light so you can see it from the driver's seat.
2. Turn key to run, and within 10 seconds press the cruise control ON button.
3. One pulse should be output to indicate the test is in progress.
4. Press in sequence: cruise control OFF, COAST, ACCEL, and RESUME buttons. Tap the brake pedal once to light the brake lamps.
5. Codes will be output (11 is a pass).
Key On Engine Running (KOER) codes 27 - Servo vacuum bleeding down
28 - Servo vacuum bleeding down (possible dump valve problem)
36 - Cannot increase engine speed (possible vacuum or cable problem)
37 - Cannot decrease engine speed (possible throttle cable binding problem)
Speed sensor: If the cruise control passes the self tests but still does not work, check the speed sensor and circuit, or substitute a new one. Key On Engine Running (KOER) test: Make sure the vehicle is safe to run (see precautions at the beginning of this document).
1. Hook up per KOEO test above.
2. Start engine and within 30 seconds, press the cruise control ON button.
3. Within 15 seconds, hook up the test trigger (or move the switch on some testers).
4. One pulse should be output indicating the test is in progress.
5. Code(s) will be output after test is finished (11 is a pass). See figure below.
EEC IV vehicles have two connectors for self testing the system.
They are located on the firewall or the left or right front fender.
The large connector contains the self test output (STO) and ground (SIG RTN).
The small pigtail is the self test input (STI). NOTE: Vehicle should be fully warmed for all tests. Key On Engine Off (KOEO) codes
23 - See regular EEC code 23
47 - Switch(es) inoperative
48 - Switch(es) stuck On
49 - Switch ground open
53 - See regular EEC code 53
63 - See regular EEC code 63
67 - See regular EEC code 67
74 - No brake On\Off cycling (possible short to ground)
75 - No brake On\Off cycling (possible short to power)
81 - Servo Vent solenoid circuit problem
83 - Servo Vacuum solenoid circuit problem
http://www.thorssell.net/hbook/images/4hup96.gif [EEC Tester hookups]

Ford Cruise Control - How it works
Amplifier The Amplifier (Amp) is the "brains" of the system. It simply senses road speed from the Vehicle Speed Sensor (VSS) and opens and closes the throttle to try and maintain that road speed.
Servo

Vehicle Speed Sensor The VSS is connected to the speedometer cable. Most of the later models had the speedo cable plugged INTO the speed sensor. On this type, the gear on the end of the sensor is driven by the output shaft in the transmission, and the sensor in turn drives the speedo cable. The sensor acts as a little generator. A magnet spins in a coil of wire to generate an AC voltage.
Switches The system switches are built into the steering wheel cover. Later models have ON\OFF, SET\ACCELL, COAST, and RESUME buttons. Some of the earlier systems did not have the RESUME. The switches have a ground circuit and also get 12 volts through the coil of the horn relay. By the way, unlike most other brands, Fords during the years that this cruise was used only had a horn relay if they had cruise. We used to get calls all the time from people looking for the horn relay on non-cruise equipped cars.

One wire goes from the switches to the Amp. I'll refer to it as the "switches" wire in this explanation.----> Here's how the switches operate: The ON button when pressed puts positive (about 12 volts) to the "switches" line. The OFF button when pressed grounds out the "switches" line. For the other functions, the buttons switch a resistor between ground and the "switches" line. The Amp senses the different resistances and performs the necessary function

The Servo contains a large diaphragm along with two solenoids and a feedback potentiometer. The diaphragm is attached by a cable to the carburetor or throttle body linkage. Engine vacuum is supplied to the Servo through a vacuum check valve which only allows vacuum to go one way. The two solenoids are for Vacuum and Vent. One side of each solenoid is connected to battery positive with the key on. To activate a solenoid, the Amp grounds out the other side of it. When the Amp wants to open the throttle, it activates the Vent solenoid which blocks it off. It then pulses the ground on the Vacuum solenoid to apply vacuum to the diaphragm. The diaphragm pulls the throttle open a little more each time the Vacuum solenoid is pulsed. The Amp keeps activating the Vacuum solenoid until the desired throttle opening is reached. The Amp also uses the feedback potentiometer to determine how much the throttle is moving and bases its adjustments on that. Even if the Vacuum solenoid stops applying vacuum, the diaphragm will hold its position. It won't release the vacuum until the vent solenoid ground is released. Then the vacuum gets dumped to the atmosphere. If the Amp just wants to let the throttle go a small amount (going too fast for example) it will momentarily ground the Vent solenoid to dump a small amount of vacuum.

Brake Light Switch The Amp has a wire coming from the brake lights. It senses the brake light voltage when the operator steps on the brakes and disengages the cruise control. Note: The Amp is also set to look for a resistance to ground through the brake light bulbs. As a safety feature, if it doesn't see this ground, it won't operate because it thinks the wire to the brake light switch may be broken. Bottom line is that if both brake light bulbs are burned out, the cruise won't work. I've seen it happen a few times.

Clutch Switch Vehicles with manual transmissions also have a switch that opens when the clutch is pushed in. This keeps the engine from revving up.
The clutch switch is wired in with the brake light switch so that it breaks the circuit to the brake light bulbs. Due to the safety feature mentioned with the brake lights above, the systems disengages.

Vacuum Dump Valve Later systems have a vacuum dump valve on the brake pedal. A vacuum line is connected from the valve to the Servo diaphragm. When the brake pedal is pushed, vacuum in the Servo is released (dumped). This is another safety feature. In the earlier models without this valve, when the brake light switch went bad and you were using the cruise, the more you tried to stop the car the more the Amp tried to accelerate.
Reply With Quote
  #7  
Old 11-16-2012, 12:33 PM
Ford Pickup
 
Join Date: May 2012
Posts: 113
Default Re: Cruise control not working

Quote:
Originally Posted by SilveRanger01 View Post
My cruise control has not worked for about a year now, and since I've only gotten a job recently, have I thought about fixing it. Here are the specs for my Ranger:

Year: 2001
Model: Supercab XLT
Engine: 4.0L V6
Trans: Automatic, 4wd


Problem: When I turn my cruise "on" and hit 'set', the 'speed control' indicator will flash on the dash for a brief second, then go off, with the cruise not being set or even working. It will only 'flash' once, until I turn it off and back on again, will it flash again. Any thoughts you might have or suggestions are greatly appreciated! Thanks!

Gerrit
I have this exact same problem. Do you have a part number?
__________________
2001 Ford Ranger XLT Supercab, 4.0, 5-speed, 4x4, 4.10's, 31x10.50 Duratracs
Reply With Quote
  #8  
Old 01-10-2014, 01:17 PM
Learning to use the forums
 
Join Date: Jan 2014
Posts: 1
Default Re: Cruise control not working

I have a 94 Ranger 4x4 with the cruse not working and I can not find a brake pressure switch mounted just in front of the resevoir on the master cylinder . I just put a new Master cylinder on and did not see anything else . It worked one time then quit . Have checked the fuse .
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Discuss How To: 98-00 Cruise Control Pod Lighting Fix/Mod 99offroadrngr How-To Submissions 4 01-24-2011 06:35 PM
Cruise Control Help ranger4.0 Electrical Tech 4 02-14-2010 11:33 AM
Cruise Control bassplyer92517 Electrical Tech 5 02-07-2010 07:46 PM
cruise control kb4422 Electrical Tech 30 07-27-2009 05:40 PM
cruise control bigblock119 General Tech 0 06-15-2009 07:35 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.