Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-02-2009, 07:55 PM
bwheeler bwheeler is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 9
Question Instrument Cluster/Tail Lights/Fog Lights - NO Lights when Headlamps are on???

I have an '01 Edge (6cyl, 3.0L, Auto) - at night when you turn the headlamp switch on . . . entire cluster guages don't light up, fog lamps don't light up, and taillights aren't working (the headlights do turn on though).

Not even sure where to start . . . I have checked the fuses thoroughly (made sure - by the book, there was the right fuse at the right amperage in the right spot, but everything was fine).

If anyone can help . . . please - my car isn't legal at night until I fix this

Brandon
Reply With Quote
  #2  
Old 05-04-2009, 07:39 AM
bwheeler bwheeler is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 9
Default

I think it might be either the headlight or dimmer switch - anyone ever experienced a similar problem?

Really appreciate any comments here!

Thank you again.

Brandon
Reply With Quote
  #3  
Old 06-02-2009, 12:18 PM
dogboy dogboy is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2009
Posts: 24
Default

i had that same problem with my 91 now dont take my word for it because there is a ten year gap between our vehicles and the factory could have changed the wiring but in my truck all i had to do was replace a fuse that was under the dash
__________________
future scraper
Reply With Quote
  #4  
Old 06-02-2009, 09:47 PM
littleblue littleblue is offline
Semper Paratus
 
Join Date: May 2009
Posts: 274
Default

Quote:
Originally Posted by dogboy View Post
i had that same problem with my 91 now dont take my word for it because there is a ten year gap between our vehicles and the factory could have changed the wiring but in my truck all i had to do was replace a fuse that was under the dash
ditto, most cars when the dash and taillights go out it is usually the fuse. if it keeps happening though, you need to find out whats cause to fuse to blow.
Reply With Quote
  #5  
Old 06-03-2009, 05:52 AM
bwheeler bwheeler is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 9
Default

I found the issue - the previous owner had the ground attached to the power source for his HID lights. Blew the fuse once you turned it on (every time)!

Thank you for all the replies!
Reply With Quote
  #6  
Old 06-03-2009, 11:14 PM
dogboy dogboy is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2009
Posts: 24
Default

what is your opion on the HID kit iv been considering doing it but i want some information from people who are currently or have used them before i decide to buy them
__________________
future scraper
Reply With Quote
  #7  
Old 06-05-2009, 05:35 AM
bwheeler bwheeler is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 9
Default

It looks cool (I mean the lights are very bright and blue) however, I think it could be illegal actually.

Although, I've already replaced the alternator with a more powerful version - just to accomodate the extra power needed. Plus its rather expensive - even if you buy the system through ebay!

Its up to you!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 Ranger fog lights tunnelturn Electrical Tech 4 02-14-2017 09:57 AM
1973 Head Lights jahylton Electrical Tech 1 06-02-2009 07:48 AM
99 Ranger 4X4 lights flashing sacalait59 Drivetrain Tech 3 05-27-2009 02:58 PM
Reverse Lights Not Working Jenkins95 Electrical Tech 2 05-23-2009 01:02 AM
Ford Ranger, 2001, Fog lights? Wood Chip Electrical Tech 3 11-26-2008 11:25 PM