Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-14-2010, 09:08 AM
jp13 jp13 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 8
Default both brake lites out

my son has a 99 ranger that has both brake lites out. I will change the fuses and bulbs, but was wondering if it could be the trailer hook-up. He had a minor accident with it , when I checked the truck over the trailer hook up was hanging off the rear bumper. I wil check the connections. any help would be appreciated.
Reply With Quote
  #2  
Old 02-14-2010, 11:55 AM
whfd930 whfd930 is offline
930 in route, CODE 3!
 
Join Date: Feb 2010
Posts: 41
Default

either that, the maxi fuse under the hood, the plug assy that attaches wiring harness from front to back, or the brake light switch on the pedal itself. These are all things that have happened to me. Best of luck
__________________
Quote:
Originally Posted by 2001xlt4d View Post
Quote:
Originally Posted by surfer03133 View Post
it can get tough to get the tool to fit in the slot,
Quote:
Originally Posted by Steviejay View Post
Haynes: Remove small retaining clip.
Translation: Take off 15 years of stubborn crud, it's there somewhere..
Translation: Break every screwdriver in your box.
Haynes: This is a snug fit.
Translation: You will skin your knuckles! ... Clamp with adjustable wrench then beat repeatedly with hammer.,



2003 single cab, Edge package, 3.0 5sp 2wd
Red and blue lights all around
Icom 7000 Ham radio w/75m resonator and 2m/440 5/8 wave
Reply With Quote
  #3  
Old 02-14-2010, 02:45 PM
jp13 jp13 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 8
Default

Thanks,I changed bulbs and fuses looked ok. I will look at the others. thx again.

Last edited by jp13; 02-14-2010 at 02:50 PM.
Reply With Quote
  #4  
Old 02-15-2010, 01:01 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by jp13 View Post
Thanks,I changed bulbs and fuses looked ok. I will look at the others. thx again.
I bet it is a 5 speed
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 02-17-2010, 03:26 PM
jp13 jp13 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 8
Default

Nope automatic.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Issues Barney Drivetrain Tech 7 05-03-2010 06:18 PM
brake help RangerLuc General Ford Ranger Discussion 33 12-10-2009 02:02 PM
brake help (new) RangerLuc General Ford Ranger Discussion 1 11-17-2009 02:36 PM
Need brake advice. FireRanger General Ford Ranger Discussion 9 09-26-2009 12:09 PM
Brake Work dentonguy Drivetrain Tech 4 09-23-2009 06:46 AM