Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-24-2010, 10:10 AM
speterson speterson is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 2
Question Tach quit working

Probebly a little history. My check engine light came on awhile back. I did the ignition on/off to get code.. it said EGR ok I out new on.. it went off awhile then has came back on. I changed spark plugs and now my tach quit working. I put new wires on. that didnt help. I have the 2.3 dual ignition so 8 wires and plugs and 2 coils. when its real cold out it barly fies and the tach starts to work but runs really really rough. then idle smooths out and tach goes to zero then wont come back up. Do you think I lost a coil? Or should I look for something else.
Please help. Motor runs smooth but seems to have a loss of power.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Ranger Speedometer quit working? wrongfulleaf Electrical Tech 28 09-11-2013 06:49 PM
Tach mmguy Interior Tech 8 02-11-2010 04:50 AM
speedometer quit working blackandgreen98 Electrical Tech 5 01-22-2010 09:56 AM
Tach Gauge earnbud Interior Tech 4 01-06-2010 07:03 AM
30 second bell and the tach drops down and up . . . khgxdctv Electrical Tech 0 11-11-2009 05:19 PM