Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-17-2010, 08:52 PM
blackandgreen98 blackandgreen98 is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 36
Default speedometer quit working

this is the deal. it was acting werid at frist(drove for 5 mins no problem and then after 5 mins it starts to f**k up). okay im getting fed up, i replaced the sensor and i thought it was all good....wrong. so im asking you guys wtf is wrong with it now. thanks in advance
Reply With Quote
  #2  
Old 01-18-2010, 02:53 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Check you connection on the sensor maybe not all the way on.
__________________
2005 Edge

Reply With Quote
  #3  
Old 01-18-2010, 07:50 AM
blackandgreen98 blackandgreen98 is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 36
Default

Quote:
Originally Posted by STL View Post
Check you connection on the sensor maybe not all the way on.
did. it used to work for a lil bit and now it doesnt work at all.
Reply With Quote
  #4  
Old 01-18-2010, 08:26 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default

What year is it? Which sensor did you replace?
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #5  
Old 01-18-2010, 08:54 AM
blackandgreen98 blackandgreen98 is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 36
Default

Quote:
Originally Posted by rwenzing View Post
What year is it? Which sensor did you replace?
1998, and its called the abs sensor, in the rear end
Reply With Quote
  #6  
Old 01-22-2010, 10:56 AM
blackandgreen98 blackandgreen98 is offline
Like the Forums
 
Join Date: Nov 2009
Posts: 36
Default

seriously? i got more help from a racing site. so i ask peope who all have rangers and i get no help what so ever?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Ranger Speedometer quit working? wrongfulleaf Electrical Tech 28 09-11-2013 06:49 PM
speedometer, odometer, and dome light are not working bigkehoe Electrical Tech 15 03-30-2013 01:12 PM
speedometer HELP camoman Electrical Tech 3 11-25-2009 05:58 AM
Speedometer is off, at best Momboy007 General Tech 3 11-15-2009 12:10 AM
ABS AND Speedometer Jackal General Tech 1 06-24-2009 07:54 AM