Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > Electrical Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 01-21-2009, 01:01 PM
Learning to use the forums
 
Join Date: Jan 2009
Posts: 2
Send a message via Yahoo to MrPlumber
Question Electrical Problem

Wassup folks. I've got a weird electrical issue I can't seem to put my finger on. About a year and a half ago, I purchased a 1999 Ford Ranger EX cab V6, 3.0. It has been an outstanding truck, and I absolutely love it. However..I never looked into it before purchasing it to see if it was wrecked..flooded..or whatever. But maybe you can help me out, here's the issue

Whenever I drive the truck, it drives great. Anytime I apply the break, my radio lights dim a little, and so does the dash lights come on. (This is with the running lights turned off during the day) Turning on the blinker..my radio light dims with the clicking of the blinker. My blinker finally started working correctly, but sometimes seemed like it would short. I think I hit a good bump and it works good now. My break lights went out for a while, but when I hit a bump it returned, so I ended up putting some electrical tape on the connections close to the light, and no problems ever since..lol. So, thats the electrical issues with it. Everything works, just..weird..any advice would be appreciated.
Reply With Quote
  #2  
Old 06-08-2010, 10:34 PM
Learning to use the forums
 
Join Date: Jun 2010
Posts: 3
Default Re: Electrical Problem

Mr Plumber - If you find out what's causing the problem, let me know. I have a 1994 Ranger, 6cyl. I just bought it and I noticed everytime I step on the brakes my dash lights come on as well as my front parking lights, and the radio light dims. Let off the brakes and they go out. It has me puzzled. Obviously an electrical problem and I'm thinking maybe the headlight switch is just bad.
Reply With Quote
  #3  
Old 06-09-2010, 04:45 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Electrical Problem

Find the trailer light harness in the back. $5 says it is all corroded to hell is causing your stop/tail/turn circuits to cross with the parking light circuit.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #4  
Old 06-10-2010, 08:52 AM
Learning to use the forums
 
Join Date: Jun 2010
Posts: 3
Talking Re: Electrical Problem

You are a man of much wisdom FireRanger. Checked the towing wire harness last night (as a matter of fact I removed it). Put it all back together and everything works fine.
Thank you my friend:
Reply With Quote
  #5  
Old 12-14-2010, 11:18 PM
Liking the Ford Ranger Forum
 
Join Date: Oct 2010
Posts: 21
Default Re: Electrical Problem

I have a brainteaser for someone out there. My tail lights work but when i brake the left taillight goes out completely. if the lights are off both brakelights work perfectly.
Reply With Quote
  #6  
Old 12-14-2010, 11:44 PM
www.shanewootenband.com
 
Join Date: Oct 2010
Posts: 1,694
Default Re: Electrical Problem

Quote:
Originally Posted by andre bayards View Post
I have a brainteaser for someone out there. My tail lights work but when i brake the left taillight goes out completely. if the lights are off both brakelights work perfectly.
some one hacked up the rear harness?, brake light positive is touching park light ground.. or vice versa
__________________
1999 MAZDA 2500SE, 2.5L 4-clanger, 5 speed, Green n slow. Rangers as daily drivers since 1988.
ASE Certified Mechanic, Builder of Show Destroying Protouring and Classic cars..
Reply With Quote
  #7  
Old 12-14-2010, 11:50 PM
Do not touch the trim!
 
Join Date: Aug 2010
Posts: 2,737
Default Re: Electrical Problem

I was gonna suggest check the battery/chassis grounds... never thought of the trailer harness.
__________________
'96 XLT, 4.0L, 4x4 Auto, Super Cab, K&N Filter, Dual Exhaust, 200a Alt, Clear Corners, BUGGMAN LED's, Expo Power Seats & Console, LED modded '01 Tails

Need LED's? Send me a PM
LINKS... Click 'em - - -> BUGGMAN PICS - - -BUGGMAN'S YouTube Channel - - -BUGGMAN'S FaceBook
Reply With Quote
  #8  
Old 12-15-2010, 07:52 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Electrical Problem

Quote:
Originally Posted by andre bayards View Post
I have a brainteaser for someone out there. My tail lights work but when i brake the left taillight goes out completely. if the lights are off both brakelights work perfectly.
This is probably either corroded lightbulb sockets, a corroded trailer light connector, or hacked up wiring along the way. You'll have to trace it out manually.

It won't be the brake light shorting to ground, that would pop fuses.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #9  
Old 01-03-2011, 06:57 AM
Learning to use the forums
 
Join Date: Jan 2011
Posts: 1
Default Re: Electrical Problem

I have a 98 ranger, and mine has problems. My 4WD, interior light, and wipers work or don't work at the same time. Never knew these things had any wiring in common. I have replaced modules, cleaned and checked connections, but some common denominator is somewhere. Maybe Ford can look into these issues and set-up a recall.
Reply With Quote
  #10  
Old 02-04-2011, 05:18 AM
old but not dead!
 
Join Date: Jan 2011
Posts: 12
Default Re: Electrical Problem

The majority of 12V problems come from a faulty ground circuit.When a circuit draws enuf current (2 bulbs lit) it needs more ground to get the juice back to the battery.this causes 1 lite to work instead of 2.
__________________
I have a 2003 Ranger Edge,4.0 V-6 auto,4x4.Factory 3" lift and 16" steel wheels.
Reply With Quote
  #11  
Old 03-16-2011, 05:39 PM
Learning to use the forums
 
Join Date: Mar 2011
Posts: 2
Default Re: Electrical Problem

Quote:
Originally Posted by JonNeeley View Post
I have a 98 ranger, and mine has problems. My 4WD, interior light, and wipers work or don't work at the same time. Never knew these things had any wiring in common. I have replaced modules, cleaned and checked connections, but some common denominator is somewhere. Maybe Ford can look into these issues and set-up a recall.
If you have figured this out please let me know because I am having the same problem with my 1999 ford ranger xlt extended cab. Everything worked fine the last time I drove the truck and I got in it today and the windows, dome light, key dinger,4x4, and the windshield wipers dont work. Thanks.
Reply With Quote
  #12  
Old 03-17-2011, 07:04 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Electrical Problem

Have you opened your owners manual and checked the fuses that would apply to these devices? Those things are all on several different fuses though so it could be something else. Have added/modified/changed/wired anything in the cab?
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #13  
Old 04-22-2011, 10:04 AM
Learning to use the forums
 
Join Date: Mar 2011
Posts: 2
Default Re: Electrical Problem

Hi All,
I am a first time Ranger owner. I picked up a 98 XLT for cheep money, and I also have an electrical issue. My 4-way flashers and directionals are not working. Neither is the radio. I replaced the flasher under the dash, but still no luck. Parking and tail lights work fine.

When I checked the fuses, they are fine. But on the radio, there is no power to the fuse at the side of the dash. I think I need to check the wires between the fuse panel to the battery. Anyone else have to do this? Is this common?

Thanks,
Kevin
__________________
Kevin from RI

1998 Ranger XLT Step side, 2.5 Liter, Automatic

Bought it in February, this year. It was not well cared for, and I'm reconditioning her.
Reply With Quote
  #14  
Old 09-09-2014, 10:23 AM
Learning to use the forums
 
Join Date: Sep 2014
Posts: 2
Cool Re: Electrical Problem

Quote:
Originally Posted by lazy5411 View Post
If you have figured this out please let me know because I am having the same problem with my 1999 ford ranger xlt extended cab. Everything worked fine the last time I drove the truck and I got in it today and the windows, dome light, key dinger,4x4, and the windshield wipers dont work. Thanks.
98 Ranger.. first power windows started having issues...only rolling up on occasion. Then windshield wipers started having same issues, as well as the dome light. No ding when keys are in ignition... probably more I am missing. Checked fuses and relay. I am guessing a short..maybe ground... Not really sure. I hate to have to get a new vehicle, but the windshield wipers not working cause a safety hazard. My check engine light stays on, but mechanics (went to several about this before other issues started) can't find what is causing it to stay on. I really would love to figure this out. Thanks in advance for any help or advice!!!
__________________
1998 Ford Ranger 4X4 Super Cab XLT
4.0L EFI V6 5 SPD AUTO O/D Transmission
Light denim blue, flare side and a little chrome

Last edited by tellarae; 09-09-2014 at 10:53 AM.
Reply With Quote
  #15  
Old 09-09-2014, 10:56 AM
Learning to use the forums
 
Join Date: Sep 2014
Posts: 2
Default Re: Electrical Problem

I have electrical issues as well it seems. Power windows started having issues...only rolling up on occasion. Then windshield wipers started having same issues, as well as the dome light. No ding when keys are in ignition... probably more I am missing. Checked fuses and relay. I am guessing a short..maybe ground... Not really sure. I hate to have to get a new vehicle, but the windshield wipers not working cause a safety hazard. My check engine light stays on, but mechanics (went to several about this before other issues started) can't find what is causing it to stay on. I really would love to figure this out. Thanks in advance for any help or advice!!!
__________________
1998 Ford Ranger 4X4 Super Cab XLT
4.0L EFI V6 5 SPD AUTO O/D Transmission
Light denim blue, flare side and a little chrome
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio and 4x4 electrical problem DQuinn Electrical Tech 0 06-04-2009 11:30 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.