Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > Electrical Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-12-2012, 08:46 PM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Hazards Work, Turn Signals Don't

I'm stumped here, ready to take it in to the shop.

I replaced my headlight switch with one I found at the jy because my bulb had gone out. When I replaced all the panels and reconnected the battery, I found that my turn signals no longer work. Here's a summary:

1) Turn signals don't work, no clicking, no arrows lighting up, nothing.

2)Everything else on the switch still works, wipers, high beams, windshield fluid

3) All related fuses checked out ok, I found the flasher unit under the dash next to the obd-ii connector, and it seems to be fine. It clicks when the hazards are on, and they work fine. Just no turn signals.

4)I checked for loose wires and didn't see anything obvious. I cleaned the contacts with contact cleaner, and even replaced the original headlight switch. no change.

I can't imagine what I could've done to cause this, I was pretty careful with the headlight switch installation. Any ideas from you diagnosticians out there? Any other obvious things I should check that I may have missed? Thanks.
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
  #2  
Old 02-12-2012, 10:02 PM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Re: Hazards Work, Turn Signals Don't

Forgot to add: Could be related, but sometimes I have to turn the headlight switch off and on several times before the instrument cluster, fog lights, park lights, and tail lights will come on. That's one of the reasons I originally changed the switch, but the problem persisted with the new switch, and in fact it seems to happen more frequently now, even though I changed it back to the old switch. So confused..
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
  #3  
Old 02-12-2012, 10:59 PM
No F***s Given
 
Join Date: Jun 2010
Posts: 12,146
Default Re: Hazards Work, Turn Signals Don't

replace the bulbs first. or check them. they are dual filament bulbs. i think one of the filaments is busted. after that check the relays.
Reply With Quote
  #4  
Old 02-13-2012, 03:04 AM
Ford Ranger Driver
 
Join Date: Feb 2010
Posts: 3,123
Default Re: Hazards Work, Turn Signals Don't

flasher is bad. the turn signal part and the hazard part are two different things inside one flasher. when i was doing some led work, i shorted out the turn signals, but the hazards still worked.
__________________
Krylon Fusion is for Amateurs.
Reply With Quote
  #5  
Old 02-13-2012, 09:22 AM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Re: Hazards Work, Turn Signals Don't

Thanks guys, I'll replace the flasher first, then the bulbs. Autozone says the only replacement flasher they have is an EP27 with 5 prongs, where my OEM blue flasher has a small sixth prong in the corner. Will this make a difference?
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
  #6  
Old 02-13-2012, 09:41 AM
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,968
Default Re: Hazards Work, Turn Signals Don't

ep 27 flashers are used when people put leds in the turns, if you plan to do that, get that
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #7  
Old 02-13-2012, 10:28 AM
Ford Rangers
 
Join Date: Oct 2009
Posts: 203
Default Re: Hazards Work, Turn Signals Don't

the flasher is fine if the hazards work. theres a relay undar the dash that controls the turn signals, found out the hard way when ford charged me 120 bucks just to replace it
__________________
2002 Ranger Edge 2wd | 3.0 v6 auto 8.8 4.10 L/S | 32x11.50 Mud Kings | 28% tint | Chevy Shackles | Cranked B T-bars | Westin Bull bar w/ KC longrange| Three-tone airhorns | air box mod | k&n drop-in | foglamp mod | explorer ohc | alpine headunit | 10" mtx thunder 4500/custom box | kenwood amp| 4 wheel disk brakes | line of fire
Reply With Quote
  #8  
Old 02-13-2012, 10:59 AM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Re: Hazards Work, Turn Signals Don't

Quote:
Originally Posted by blueranger789 View Post
the flasher is fine if the hazards work. theres a relay undar the dash that controls the turn signals, found out the hard way when ford charged me 120 bucks just to replace it
Any idea where exactly that relay is, or what it looks like?
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
  #9  
Old 02-13-2012, 01:20 PM
Do not touch the trim!
 
Join Date: Aug 2010
Posts: 2,636
Default Re: Hazards Work, Turn Signals Don't

The ep27 will be a good investment if you're gonna use led turns anyhow. The little mini pin shouldn't make any difference though.

It might be that you have a bad connection in the plug that goes to the headlight switch itself (on the truck side). Try wiggling each wire around one at a time to see if anything happens, if you get lights on a certain wire, that's likely the culprit.

If that's the issue, you can get a new connector from the JY, & just splice it in with butt connectors & you should be good.

Another thought is the "new" switch is bad too... stranger things have happened.

The other relays should be under the dash (driver's side) in a small box about 3"x4" with a black cover. These will be the small rectangular relays (not the normal larger square relays we're all used to seeing). Pull each relay (one at a time) & check it's contacts to make sure they're not gunked up.

Those little relays are EXPENSIVE at the auto parts stores, like $15 each expensive... I had to buy one a while back when I had issues & turns out that wasn't the problem.
Anyhow, if you can grab some of those relays from the JY, get a handful, they can be live savers



If none of that works, it could be the multifunction switch (turns, wipers, etc) that's having the issue. Mine went bad & it drove me crazy... I couldn't drive in the rain for months until I got a new one.
Check the contacts for corrosion or gunk, spray a little wd-40, the usual remedies.
__________________
'96 XLT, 4.0L, 4x4 Auto, Super Cab, K&N Filter, Dual Exhaust, 200 amp Alternator, Clear Corners, BUGGMAN LED's, Explorer Power Seats & Console, 4x Fog Radio Bezel, LED modded '01 Tails

Need LED's? Send me a PM
LINKS... Click 'em - - ->BUGGMAN PICS - - - - - BUGGMAN MODS YouTube Channel
Reply With Quote
  #10  
Old 02-13-2012, 05:15 PM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Re: Hazards Work, Turn Signals Don't

Thanks for the advice, Bugg. I did a thorough check for loose wires and dirty contacts, and everything seems to be fine. I didn't find the black box under the dash where the other relays are, though. I searched the threads and found where it is on some earlier models, but did they maybe change it up in 04? I can't find a 3x4 black box anywhere under there.

Here's where I saw the black box on other trucks, but it's not there on mine:


And this is underneath my steering column, I already replaced the blue flasher with an EP27, and no change:
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
  #11  
Old 02-13-2012, 09:33 PM
Do not touch the trim!
 
Join Date: Aug 2010
Posts: 2,636
Default Re: Hazards Work, Turn Signals Don't



I keep forgetting Ford moved stuff around on the newer trucks

I know somebody will chime in with the location of that relay box though. Seems like mine had 6 or 8 of the small relays in it... might have been a little smaller/larger, that was just a guess
__________________
'96 XLT, 4.0L, 4x4 Auto, Super Cab, K&N Filter, Dual Exhaust, 200 amp Alternator, Clear Corners, BUGGMAN LED's, Explorer Power Seats & Console, 4x Fog Radio Bezel, LED modded '01 Tails

Need LED's? Send me a PM
LINKS... Click 'em - - ->BUGGMAN PICS - - - - - BUGGMAN MODS YouTube Channel
Reply With Quote
  #12  
Old 02-14-2012, 07:04 PM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Re: Hazards Work, Turn Signals Don't

Just like my girlfriend: every time i think i know where something is, she moves it somewhere else. lol.

Anyhow, I'm gonna break down and take it in to a buddy's shop on thursday to get it diagnosed and fixed. It's getting a little too chilly for hand signals.
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
  #13  
Old 02-14-2012, 10:09 PM
Do not touch the trim!
 
Join Date: Aug 2010
Posts: 2,636
Default Re: Hazards Work, Turn Signals Don't

I only have ONE hand signal & it's universal
__________________
'96 XLT, 4.0L, 4x4 Auto, Super Cab, K&N Filter, Dual Exhaust, 200 amp Alternator, Clear Corners, BUGGMAN LED's, Explorer Power Seats & Console, 4x Fog Radio Bezel, LED modded '01 Tails

Need LED's? Send me a PM
LINKS... Click 'em - - ->BUGGMAN PICS - - - - - BUGGMAN MODS YouTube Channel
Reply With Quote
  #14  
Old 02-15-2012, 09:06 AM
Ford Ranger Driver
 
Join Date: Dec 2010
Posts: 2,761
Default Re: Hazards Work, Turn Signals Don't

Quote:
the multifunction switch (turns, wipers, etc) that's having the issue
Ford had a recall affecting Rangers and the multifunction switch was the culprit. There is a couple posts on here because the recall affected vehicles as far back as 02' or 03', I believe. Also, ehow is a decent site for finding info. Hope this helps.
Reply With Quote
  #15  
Old 02-21-2012, 04:33 PM
Ground Control
 
Join Date: Dec 2011
Posts: 121
Default Re: Hazards Work, Turn Signals Don't

Kudos to Buggman and fifthranger, it was the multifunction switch after all! Picked one from the JY for 17 bucks and problem solved. Thanks guys!

Quote:
If none of that works, it could be the multifunction switch (turns, wipers, etc) that's having the issue.
Quote:
Ford had a recall affecting Rangers and the multifunction switch was the culprit. There is a couple posts on here because the recall affected vehicles as far back as 02' or 03', I believe. Also, ehow is a decent site for finding info. Hope this helps.
__________________
2004 Black Ranger Edge Supercab
4.0L SOHC, 5 Spd Manual
Flowmaster 40 Series Single In Dual Out
31X10.50R15 Federal Couragia A/Ts
Bedlined: Mustang Dome, Explorer OHC w/ Buggman LED Panel , Radio Bezel
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flashers work, turn signals don't kennyb Electrical Tech 0 01-10-2012 04:50 PM
Turn signals don't work!!?? Help NPRanger12 Interior Tech 5 06-28-2011 07:46 PM
turn signals wont work. Stolley94Ranger Electrical Tech 2 03-27-2011 01:19 PM
Turn Signals and Hazards stopped working all of the sudden. Suggestions? holyriverjordan Electrical Tech 6 05-24-2010 11:03 AM
no hazards or turn signals or speedo 99 xlt 2wd 5spd DSMissed Electrical Tech 14 12-27-2009 01:09 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.