Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-20-2009, 05:02 PM
MartSprat MartSprat is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 1
Default 1992 Ford Ranger Electrical Problem

Hi, I was hoping someone on here might be able to give me some help or a at least a good starting place. I'm having an electrical problem with my 1992 Ford Ranger, 4cyl pick-up.

Let me first say that the Battery is fairly new and has been tested with no problems found. When I open the cab door the dome light comes on like normal. When I go to crank the engine the entire car's electrical system dies, including the dome light that was previously working. Now when I say go to crank, I mean simply turn the key from off to the on position, it doesn't rev the starter at all or make any sound other than the clicking from turning the key to on. It will do the same thing if I turn on the head lights when I get in the truck, it'll just die the same way.

Now after a few minutes or disconnecting the negative battery cable for a while the car I'm guessing resets itself and the dome light will come back on but if I go to crank or turn on lights it faults out again. I've checked the fuses, replacing the Ignition and head lights fuses. I've also checked with a voltmeter and am getting 12.4 volts on the battery.

I'm at a loss as to what the problem could be, if anyone can give me any advice on this issue I would greatly appreciate it.

-Martin
Reply With Quote
  #2  
Old 12-20-2009, 06:00 PM
DHEM DHEM is offline
Resident Red
 
Join Date: Dec 2009
Posts: 1,003
Default

Try checking the starter solenoid.
__________________
'05 2wd Ranger xl with the 3.0

MODS-Alpine head unit, throttle cable mod, Black Rock wheels, FX4 lvl II axle swap, pooleo's camo painted bezel and mustang dome, painted/aftermarket headlights/tails fold-a-cover and over 100 hp in stickers
Reply With Quote
  #3  
Old 12-20-2009, 06:04 PM
rdnekgt rdnekgt is offline
Ford Truck Driver
 
Join Date: Dec 2009
Posts: 98
Default

replace the termal ends that go to the battery. the connection between is bad. it will probaly start after messing with the batt. termals for a while right
__________________
2006 FX4 LEVEL II screaming yellow 15X8 ion alloy wheels with 31-10.50/15 michelle Ltx tires, daul flowmaster pipes, spyder auto headlights, pioneer deck with one 12inch sub, leer cab.
Reply With Quote
  #4  
Old 12-20-2009, 07:54 PM
Buddythetruck Buddythetruck is offline
Eat-Sleep-Mod
 
Join Date: May 2009
Posts: 235
Default

Quote:
Originally Posted by rdnekgt View Post
replace the termal ends that go to the battery. the connection between is bad. it will probaly start after messing with the batt. termals for a while right
+1 did this 5 days ago, my battery corrodes like crazy.
__________________
1997 Ranger XLT GREEN SOLD.
Sony HU: Infinity 6X8's: painted interior vinyl: reupholstered and painted door panels: new vinyl floor: fo-diamond plate behind seats: Suede headliner: Two tone black/tan interior: fiberglass OHC: Black Explorer visors w/ upgraded mirrors: painted grill w/ mesh in grill: locking tonneau: 10" kicker sub: pioneer amp: racing stripes: blacked out tailights: custom paint on rims and hubcaps: Painted bumpers: rocker stripes: More mods that won't fit
Reply With Quote
  #5  
Old 01-24-2010, 11:52 AM
kagenokaze kagenokaze is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 3
Default

Could also be a bad ground...
Reply With Quote
  #6  
Old 04-06-2010, 09:32 PM
cf3232 cf3232 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 13
Default Re: 1992 Ford Ranger Electrical Problem

What was the problem or the fix? I have the same issue.

Thanks
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problem MrPlumber Electrical Tech 16 12-07-2016 02:56 PM
4x4 electrical problem matts93ranga Electrical Tech 2 11-05-2009 05:38 AM
99 Ranger Electrical problem jnascar General Ford Ranger Discussion 1 11-01-2009 08:03 PM
97 ranger 4.0 electrical problem fordguyforever Electrical Tech 1 09-03-2009 02:06 PM
Electrical problem! Patch97236 Electrical Tech 1 06-26-2009 02:12 PM