Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-14-2009, 08:25 PM
js250 js250 is offline
Ford Tough
 
Join Date: Nov 2009
Posts: 318
Default battery

when stopping at a red at night i will have the raio on lights and heater on the second fan speed. the compressor will turn on and off and my battery gauge goes down about a quarter form normal. what does that mean? it has a new battery its a 99 4cyl 2.5l 2wd
Reply With Quote
  #2  
Old 01-07-2010, 02:15 PM
DangerRanger2.3ltr DangerRanger2.3ltr is offline
Paul
 
Join Date: Sep 2009
Posts: 21
Default

i have the same problem with my 99. everything seems fine until i come off the gas and then everything just kinda drops, the fan speed, my subwoofer, and interior LEDS. i think it just had to do with the fact that the alternator doesnt put enough power to the battery to maintain the voltage. i am planning on upgrading my alternator pretty soon because the 400 watts i have running to my sub pretty much murders my electrical current when its turn up lol.
__________________
1997 Ford ranger. 2.3 ltr 4 cylinder 5 speed. 10" Kicker CVT, Alpine MRP-M450, Alpine CDA 9825. Flowmaster Delta 40 series. Smoked tails and corners. Black grille. Blue LED dash and interior backlighting. Front Fog Lights. Bad ass snowtires in the back.
Reply With Quote
  #3  
Old 01-07-2010, 04:39 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Alternator is probably just about toast. Unfortunately it is probably having a significant negative impact on your battery as well.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #4  
Old 01-07-2010, 10:54 PM
mb128 mb128 is offline
Member
 
Join Date: Oct 2009
Posts: 894
Default

upgrade to a high output alternator. does your lights dim when the bass hits? if it does the high output alternator will help if not fix that problem.
__________________
Muddin in the ranger, killin ricers in the f350

95 ford ranger 3.0 v6 side step 5 speed 4x4
mods: 6" bds sus lift, 33x12.5r15 bfg km2, expo OHC/expo power seats, full length expo console, 2 1/2" flowmaster super 44 cat back, 4 procomp 5" offroad lights, clear headlights and turn signals, 6k hid kit, 25% tint (fronts)

PNW CREW


Quote:
Originally Posted by Yrac View Post
Its a truck, you wanna go fast? Money = Horsepower!
Reply With Quote
  #5  
Old 01-08-2010, 11:10 AM
Pro Induction Pro Induction is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 10
Default

i am having bout the same problem but i just had my alternator built twice and it will start but seems like im drivin on battery and my alternator aint charging.......anybody have any suggestions???
Reply With Quote
  #6  
Old 01-09-2010, 12:40 AM
mb128 mb128 is offline
Member
 
Join Date: Oct 2009
Posts: 894
Default

i would just buy a new one next time i goes out dont get it rebuilt
__________________
Muddin in the ranger, killin ricers in the f350

95 ford ranger 3.0 v6 side step 5 speed 4x4
mods: 6" bds sus lift, 33x12.5r15 bfg km2, expo OHC/expo power seats, full length expo console, 2 1/2" flowmaster super 44 cat back, 4 procomp 5" offroad lights, clear headlights and turn signals, 6k hid kit, 25% tint (fronts)

PNW CREW


Quote:
Originally Posted by Yrac View Post
Its a truck, you wanna go fast? Money = Horsepower!
Reply With Quote
  #7  
Old 01-09-2010, 02:52 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Quote:
Originally Posted by Pro Induction View Post
i am having bout the same problem but i just had my alternator built twice and it will start but seems like im drivin on battery and my alternator aint charging.......anybody have any suggestions???
Well my first thought be replacing the alternator if its not working. I'm not sure what other option you have. Its like having a flat tire and asking "what should I do?"
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
replaced alternator and battery... Still have issues Wicked46 Electrical Tech 5 01-24-2010 11:56 AM
Which Battery Cables for 1996 3 liter XLT ? Guy Fawkes Electrical Tech 3 12-14-2009 05:00 AM
Did I Buy a Good Battery? aridranger03 General Ford Ranger Discussion 6 12-03-2009 01:56 PM
alternator, battery, and smell of something cooking! CMALI Electrical Tech 13 11-04-2009 11:25 AM
'04 3.0 install new battery g-ann General Ford Ranger Discussion 4 11-03-2009 07:44 PM