Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-08-2009, 03:15 PM
striper2301 striper2301 is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 3
Default 88 ranger

HELP

NO Headlights
good fuse
no 12 v at lights
could it be the main switch dimmer assy????

Thanks Todd
Reply With Quote
  #2  
Old 12-08-2009, 03:19 PM
Bird76Mojo Bird76Mojo is offline
troll extraordinaire
 
Join Date: Jun 2009
Posts: 536
Default

It's VERY common for the switch to melt at the connector. Pull it out and you'll soon know..

You may have to go to the junkyard and clip the harness out of a truck with the switch to replace yours. I had to on my 89..

GB
__________________
2001 Ranger Edge Regular cab, auto 4.0L 4x4 4.10LS

1989 Ranger Regular cab longbed, manual 2.9 4x4

Parts BroncoII's x 3

Last edited by Bird76Mojo; 12-08-2009 at 03:33 PM.
Reply With Quote
  #3  
Old 12-08-2009, 05:44 PM
rdnekgt rdnekgt is offline
Ford Truck Driver
 
Join Date: Dec 2009
Posts: 98
Default

Quote:
Originally Posted by Bird76Mojo View Post
It's VERY common for the switch to melt at the connector. Pull it out and you'll soon know..

You may have to go to the junkyard and clip the harness out of a truck with the switch to replace yours. I had to on my 89..

GB
yea happened to my 88 b2 all the time did you just put in a head unit
__________________
2006 FX4 LEVEL II screaming yellow 15X8 ion alloy wheels with 31-10.50/15 michelle Ltx tires, daul flowmaster pipes, spyder auto headlights, pioneer deck with one 12inch sub, leer cab.
Reply With Quote
  #4  
Old 12-08-2009, 10:47 PM
Yrac Yrac is offline
diMwit
 
Join Date: May 2009
Posts: 341
Default

When I first got my '88 I had the same problem, 15 bucks and a new switch everything was good. Easy install- there's a button/clip thingee on the back of the switch that holds in the shaft, pull the shaft and unscrew the trim ring.
__________________
'88 STX Super Cab 4x4
2.9 5spd 180,000 miles
Crappy Paint, Worn Parts,
Fix'em as they Break
when Nowhere is Now Here
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search