Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-19-2009, 10:21 PM
Itsa914 Itsa914 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default 91 wipers & heater blower issues

Hi all,

Brought home a 91 Ranger today. Great truck with a few issues. I can live with these issues, but would like to fix them if not to costly. First issue:

Wipers only work on high and when put in delay, low or off they stop where every they are. I must also "park" them at the bottom of the windshield by timing when I shut them off. I have a hayes manual, but well you know....

Next, heater blower only works on high speed setting. I plan to spend some time this weekend trouble shooting, but would be very greatful for any advice on what maybe the issues.

Thanks!
Reply With Quote
  #2  
Old 11-19-2009, 11:04 PM
greyghost greyghost is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 1,528
Default

Quote:
Originally Posted by Itsa914 View Post

Wipers only work on high and when put in delay, low or off they stop where every they are. I must also "park" them at the bottom of the windshield by timing when I shut them off. I have a hayes manual, but well you know....

Next, heater blower only works on high speed setting. I plan to spend some time this weekend trouble shooting, but would be very greatful for any advice on what maybe the issues.

Thanks!
the wipers sounds like a multi function switch failure to me.

and this link should help you out on your heater problem

http://www.therangerstation.com/Maga..._diagnosis.htm
Reply With Quote
  #3  
Old 11-28-2009, 06:12 AM
Itsa914 Itsa914 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default

Thanks for the info. I have a new multi function switch coming from ebay (dealer wanted $356 YIKES!) for $44. Replaced that resistor pack shown in link you provided and that fixed the heater blower problem.

Thanks again!
Reply With Quote
  #4  
Old 12-06-2009, 05:53 AM
Itsa914 Itsa914 is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default

Well replaced the multifunction switch yesterday and still the wipers only work on high. Looking at the hayes manual shows a interval governor between the switch and wiper motor. Anyone know where it is located and maybe have a part number? Thanks

Last edited by Itsa914; 12-06-2009 at 05:57 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers Don't Work! ARENG01 Electrical Tech 8 06-07-2016 01:44 PM
windshield wipers brannonmetal Exterior Tech 1 10-29-2009 04:43 PM
wipers randomely go on crarg6 Electrical Tech 2 10-10-2009 10:17 PM
heater blower moter bassined2 4-Cylinder Tech 0 10-10-2009 11:21 AM
Blower Motor garfieldfreak Interior Tech 2 06-20-2009 02:15 PM