Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-17-2009, 05:47 AM
troyfab troyfab is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default Radio and heater on 98 ranger stopped working

I searched thru all the pages but could not find anything that linked the 2 problems I have together? I checked both fuses and they are good?
Reply With Quote
  #2  
Old 11-17-2009, 06:42 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

When you say "heater" are you talking about the blower motor. Any other symptoms ie. Air bag light etc, Is your radio Factory. If it is aftermarket could it be tied in with the "heater" check your blower motor relay in the distribution box
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 11-17-2009, 06:49 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

When you say "heater" are you talking about the blower motor. Any other symptoms ie. Air bag light etc, Is your radio Factory. If it is aftermarket could it be tied in with the "heater" check your blower motor relay in the distribution box
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 11-17-2009, 07:01 AM
troyfab troyfab is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default more info

Yes, factory radio and yes fan. but also the heat too, I believe? I do not hear a click when I switch to heat or AC?
Reply With Quote
  #5  
Old 11-17-2009, 07:21 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

It most likely is a fuse I would check all the fuses in the dist box too It doesn't sound like a relay but fyi you can swap the blower and starter relay to check.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #6  
Old 11-17-2009, 07:24 AM
troyfab troyfab is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default Thanks

I will check tonight when I get home.
Reply With Quote
  #7  
Old 11-23-2009, 04:50 AM
troyfab troyfab is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 4
Default

New battery fixed all the problems
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer Stopped working! swat784 Interior Tech 15 10-05-2009 01:55 PM
98 Ranger Heater Core Questions gblyleven General Tech 2 09-30-2009 03:54 AM
How to remove radio in 90 Ranger Jays90ranger Audio / Video 9 09-29-2009 03:56 PM
Need 2000 Ranger Radio Bezel Mike Interior Parts 19 08-14-2009 06:48 PM
I have a"96 Ford Ranger XLT , While driving the other night the engine just stopped Michael N General Ford Ranger Discussion 1 01-31-2009 02:38 PM