Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-25-2011, 11:06 AM
UnderTheRose UnderTheRose is offline
Learning to use the forums
 
Join Date: Sep 2011
Posts: 3
Send a message via Yahoo to UnderTheRose
Question Turn Signal Light Problem - Wiring or something else???

Hello,
This is my first time here and I hope someone will be kind enough to help me.

I have an old, 1983 Ford Ranger. It has been sitting for a long time and I recently did a pre-state-inspection check and found that my right-hand turn signals did not work. I checked bulbs, and replaced the right rear bulb (looked burned). Checked the front and found that the 3 wires leading to the bulb socket assembly had been chewed totally through (I DID say it had been sitting a while, right?) The bulb socket came off in my hand...

Purchased a new bulb assembly from Advance. Original wiring had a white wire w/ blue stripe, a black wire, and a brown wire. New assembly came with pigtail wires of Blue, Black, and Brown. I stripped, twisted, and crimped the old wires to the new: White with blue to the Blue pigtail, Brown with Brown, and Black with Black.

I put a new bulb into the new socket and checked my lights.

I now have this situation:

Headlights on: All bulbs, front and rear, left and right, light up like normal.

Hazard Lights on: Three bulbs light up and blink. The front right (my problem child) does NOT do either.

Right Turn Signal: Front does not light or blink. Back lights up but will not blink.

Left Turn Signal: Both lights light up and blink.

Round silver fuse in fuse panel does not "look" burnt or out of the ordinary.

Do I have the wiring on the new assembly WRONG? (There were no instructions in the box with the new part...I just used what I thought was logic in matching them up. ) If this is my problem, then which color should match with which??

I don't think it is the fuse...otherwise why would the left blinker work?? But if it is, I know my way to the local Advance Auto!

Or...could it be the turn signal lever on the steering column?

Or am I totally off track here altogether?

I know I sound exceedingly dumb here, but it is the first time I've tried working on my own vehicle and it has been an...experience...to say the least...

If anyone can help, it would be most gratefully appreciated!
Thanks!
Reply With Quote
  #2  
Old 09-25-2011, 11:12 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default Re: Turn Signal Light Problem - Wiring or something else???

welcome to FRF and sounds like something is wrong with the way you hooked up your new socket...the RR turn signal staying lit is an indication of a burned out bulb...and if i remember right the RF signal is on a different circut than the LF...just look at all fuses and see if one is burnt
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #3  
Old 09-25-2011, 03:36 PM
UnderTheRose UnderTheRose is offline
Learning to use the forums
 
Join Date: Sep 2011
Posts: 3
Send a message via Yahoo to UnderTheRose
Default Re: Turn Signal Light Problem - Wiring or something else???

Thank you for help/suggestions...

Varied luck so far, but no solve... I've just run into a different set of problems...

Tried changing wires: ended up with no park lights or flashers so I switched it back.

Have bought new flasher unit (but was given wrong one...so it didn't work) Put old flasher unit in and have gotten some limited success...

I at one point had headlights and flashers working correctly...

Thinking it was fixed, I went to make permanent connections with the wires...took bulb out... connected wires...put bulb back in and nothing.

(I have turned on both the headlights and the right turn signal.)

If i seat the bulb fully into the socket...I'm getting nothing...no headlights no flasher.

If I take it out, then slide it back and and DONT turn it to lock it, I can wiggle the bulb and get various results... Wiggle one way, I get a solid glow, but no flasher, another way, and I get my flasher. Yet another way and I get nothing.

I am beginning to suspect a bad from the factory (or i somehow broke it?) light bulb assembly?
Reply With Quote
  #4  
Old 09-25-2011, 03:53 PM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default Re: Turn Signal Light Problem - Wiring or something else???

yea sounds like a bad socket
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #5  
Old 09-25-2011, 07:41 PM
UnderTheRose UnderTheRose is offline
Learning to use the forums
 
Join Date: Sep 2011
Posts: 3
Send a message via Yahoo to UnderTheRose
Default Re: Turn Signal Light Problem - Wiring or something else???

Thank you for your help!!! I'll be ordering a new one tomorrow and we'll see if it fixes it!

Thanks again!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signal problem 15danger Electrical Tech 2 04-12-2012 02:34 PM
94 Ranger turn signal problem MOOSEMAN2906 Electrical Tech 2 09-14-2011 06:46 PM
Driver side brake light won't go, turn signal still works... CooLUIS14 Electrical Tech 10 07-13-2011 08:04 PM
one peice headlight/parking light/turn signal for 1999 ranger MeanGreen3.0 General Ford Ranger Discussion 7 04-21-2011 07:50 AM
hazard/turn signal light erratic behavior dirtbagx89 Electrical Tech 10 02-03-2010 01:15 PM