Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-02-2011, 06:06 PM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default 87 runs 4-6 miles and quits

87 ranger with 2.3 stops running after 4 to 6 miles - on initial start sometimes stalls/ immediate restart and then good - just before shut down has hard time upshifting- feels like an electrical problem/signal issue -- computer self tests - engine cranks good but won't start - timing dead on - not overheating -- new components - distributor, coil, control module(TFI), pickup, trans sender, fuel and ecm relay, ECM, temp sensor - high pressure pump and filter - MAP - O2 sensor - ignition switch assembly. When it quits it can be 5 hrs before restart - it then runs a little rough like the computer is off time for about a mile and the smooths out. 6 months ago it would shut off and turning the key on and off would restart - got progressively worse - not throwing ANY codes. Truck has 358k - want to keep her - no rust and emissions 85% of new last year Suggestions please.
Andy
Reply With Quote
  #2  
Old 08-02-2011, 08:06 PM
mt1986 mt1986 is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 12
Default Re: 87 runs 4-6 miles and quits

My 86 2.3 ext cab 2x4 had the same problem, it turned out to be corroded electrical connections at the fuel injector, when I inspected them 3 of the 4 connectors were dirty. Upon cleaning them the truck runs better than it ever has, no pinging, no acting like running out of gas, huge inprovement. I had to remove the top half of the intake manifold to gain access to the injectors but it was not a difficult job, be sure to use dielectric grease when putting the connections back together, good luck
__________________
mt1986
Reply With Quote
  #3  
Old 08-02-2011, 08:09 PM
Lee_T413 Lee_T413 is offline
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 950
Default Re: 87 runs 4-6 miles and quits

could be a weak/corroded ground cable i had similar issues with an old chevy.
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #4  
Old 08-02-2011, 09:13 PM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default Re: 87 runs 4-6 miles and quits

Thanks for the feedback
Will be inspecting/cleaning injector wiring.
have been checking grounds - most are now new - still have a few to go.
Thanks again
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Ranger 532,000 Miles (Half a million miles) audyjl Introduce Yourself 25 09-16-2014 01:34 PM
87 runs 4-6 miles and quits Searcherwolfe 4-Cylinder Tech 4 08-02-2011 04:35 PM
runs 4-6 miles and quits Searcherwolfe 4-Cylinder Tech 5 05-21-2011 05:13 PM
Quits Running wotherp General Tech 0 03-07-2011 11:38 AM
6-Cyl Engine Quits On '95 XLT Gulfoyster General Tech 0 02-18-2010 08:42 PM