Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-02-2011, 07:03 PM
marksnwbrd marksnwbrd is offline
Learning to use the forums
Join Date: Nov 2010
Posts: 3
Default fuse 26!!!!

ford ranger 2002, 4x4 xlt
Fuse number 26 keeps blowing!!! it's related to the gem module so i have no speedo, wiper's, wiper wash, interior lights, chimes etc. The only wiring i have done is wiring in 2 extra lights to the rear brake lights and they are working fine!! i tried disconecting the lights i had wired but the fuse still blew!! any suggestions on a possible solution??

Last edited by marksnwbrd; 07-02-2011 at 07:07 PM.
Reply With Quote
Old 07-02-2011, 07:29 PM
FireRanger FireRanger is offline
Blinded by the light
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: fuse 26!!!!

You're up shits creek with that one man. There is nothing user serviceable or that you could have messed up on that circuit. Unfortunately my only suggestion is trying a new GEM module.
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
'02 10A blower motor relay fuse keeps blowing - up'd tp 15A fuse and blew that too drewglenn04 Electrical Tech 12 07-02-2012 12:18 PM
Fuse Block Ric Electrical Tech 6 01-21-2011 06:29 AM
fuse 19 ron315 Electrical Tech 1 12-16-2010 03:46 PM
Fuse #17 Kacy Electrical Tech 8 08-30-2010 05:58 AM
Blowing Fuse 24 Mike1987 Electrical Tech 0 05-13-2009 04:06 AM