Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-01-2011, 11:14 AM
Chambersaviator Chambersaviator is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 46
Default Speedometer and mileage don't work under 35mph

Hello,

I recently had my speedometer/gauges out looking for a short. After the meter went back in it worked well for about a day. Then all of the sudden it started not working under 30-35mph. Is it possible that I damaged it, or could it just be a coincidence? My mechanic thinks the problem has something to do with a worn out part located on the left side of the transmission.
__________________
------------------------------------------------------
99' Ford Ranger with 3.0 Standard Transmission

03' Ranger 2.3 Standard
Reply With Quote
  #2  
Old 07-01-2011, 11:16 AM
doyouquaxu doyouquaxu is offline
Almost ******
 
Join Date: Mar 2011
Posts: 7,480
Default Re: Speedometer and mileage don't work under 35mph

drive faster. go 40 or faster EVERYWHERE. tell the cops if they pull you over that it's a safety thing to ensure that your speedometer works.
__________________
Why does everyone think prerunners just jump stuff?


Please click HERE to watch this video!
Reply With Quote
  #3  
Old 07-01-2011, 01:43 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Speedometer and mileage don't work under 35mph

Quote:
Originally Posted by Chambersaviator View Post
My mechanic thinks the problem has something to do with a worn out part located on the left side of the transmission.
Not if it's a 99 Ranger. The speed signal originates at the rear axle sensor on 98~00 Rangers and has nothing to do with the transmission.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #4  
Old 07-01-2011, 07:37 PM
Chambersaviator Chambersaviator is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 46
Default Re: Speedometer and mileage don't work under 35mph

Quote:
Originally Posted by doyouquaxu View Post
drive faster. go 40 or faster EVERYWHERE. tell the cops if they pull you over that it's a safety thing to ensure that your speedometer works.
That doesn't work on the dirt roads. 25mph hour is about Max. And I live about 7 miles out so it will add up.

----------

----------

Could the problem be the rear axle sensor?
__________________
------------------------------------------------------
99' Ford Ranger with 3.0 Standard Transmission

03' Ranger 2.3 Standard
Reply With Quote
  #5  
Old 07-01-2011, 08:46 PM
pooleo pooleo is offline
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,764
Default Re: Speedometer and mileage don't work under 35mph

did you take the bezel off the front? maybe you pushed the needles inward and there sticking
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #6  
Old 07-01-2011, 08:47 PM
01B3000 01B3000 is offline
Needs moar chrome....
 
Join Date: Dec 2010
Posts: 1,319
Default Re: Speedometer and mileage don't work under 35mph

Well, my friend had a 99 3.0 auto and his rear sensor was bad, over 60 mph the speedo would go bezerk and then the truck would force downshift itself into 2nd gear, real scary. Replaced the sensor and it never happened again
__________________
2001 Mazda B-3000 CabPlus "FX2 Off Road"| 3.0 | 5 SPD | 3 In Spindle Lift | Belltech Shackles | UltraGauge |Alpine Head / 10" Kicker Setup | Air Box Mod | Add-A-Leaf| Thrush Welded B4 Rear Wheel | Kobalt Box | Cobra 19 DX IV | Custom PA Speaker | Front/Rear Tow Receiver | 2X Aux Lights | Hideaway Strobes | Back Rack Safety Rack | Amber LED Strobes | Blue LED Strobes | 265/75/R16 General Grabber AT2's
Quote:
Originally Posted by Clinton View Post
I like little girls...........
RIP Jason
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers, speedometer, odometer, dome light dont work help me please klinea7 Electrical Tech 19 04-22-2014 01:56 PM
Can not get little truck pass 35MPH 713cableman 4-Cylinder Tech 11 04-12-2011 07:25 AM
Is my speedometer still off...? BlackMoses Wheels and Tires 4 10-05-2010 03:43 PM
Speedometer doesen't work.... BoosTT General Ford Ranger Discussion 0 01-23-2010 03:33 PM
Speedometer is off, at best Momboy007 General Tech 3 11-15-2009 12:10 AM