Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > Electrical Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #16  
Old 06-03-2011, 04:39 PM
FORD RANGER.....NUFF SAID
 
Join Date: Jun 2011
Posts: 23
Default Re: No start, Clicks but no turnover, Battery drains while parked?

if you get it started and disconnect your battery and it stays running then your alternator is good if when you disconnect the battery and it cuts off your alternator is bad, just a quick way to check
__________________
1987 XLT 2.9 V6 4x4 manual gear single cab


Rollbar with Baja Lights, 15x8 cut stock wheels A/T 235/75/15 tires, no converter with a single in two out flowmaster with turn downs behind wheels, Cold air K&N intake, spray in bedliner
Reply With Quote
  #17  
Old 06-03-2011, 05:37 PM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,680
Send a message via AIM to FireRanger
Default Re: No start, Clicks but no turnover, Battery drains while parked?

Quote:
Originally Posted by rico View Post
if you get it started and disconnect your battery and it stays running then your alternator is good if when you disconnect the battery and it cuts off your alternator is bad, just a quick way to check
No that is not a good idea and you should never do that. Please don't.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #18  
Old 06-03-2011, 07:56 PM
FORD RANGER.....NUFF SAID
 
Join Date: Jun 2011
Posts: 23
Default Re: No start, Clicks but no turnover, Battery drains while parked?

Quote:
Originally Posted by FireRanger View Post
No that is not a good idea and you should never do that. Please don't.
why is that bad? will it mess something up?
__________________
1987 XLT 2.9 V6 4x4 manual gear single cab


Rollbar with Baja Lights, 15x8 cut stock wheels A/T 235/75/15 tires, no converter with a single in two out flowmaster with turn downs behind wheels, Cold air K&N intake, spray in bedliner
Reply With Quote
  #19  
Old 06-04-2011, 05:23 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,680
Send a message via AIM to FireRanger
Default Re: No start, Clicks but no turnover, Battery drains while parked?

It sure can.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #20  
Old 06-06-2011, 05:13 PM
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 16
Default Re: No start, Clicks but no turnover, Battery drains while parked?

so i did find a fuse on the stereo wire, but i'm leaving it disconnected just in case. i put a fresh battery in today and it started right up. while i had the engine running i left the door open. the door a jar warning tone was sounding and when i revved the engine the sound became garbled. i shut off the engine and tried starting it again and it fired right up a couple times. i shut it off and let it sit for about an hour. when i returned it wouldn't start again. i tested the battery and it was completly drained. i am stumped.
__________________
88 Ranger, fuel injected V6, Manual, dual fuel tank, Red, but I found a bill of sale in the glovebox from 2007 that stated at the time of sale the truck was silver and automatic trans. It has 190k on the odometer. I used to own an 88 red ranger when I was 19. It was only a 4 banger and had just one fuel tank. I pretty much bought it because it was a great deal and for nostalgia.
Reply With Quote
  #21  
Old 06-08-2011, 08:54 PM
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 16
Default Re: No start, Clicks but no turnover, Battery drains while parked?

Yeah I heard that disconnecting the batt while it's running can really mess stuff up. I did try the screwdriver trick. I know you said it wouldn't do anything but i was given that tip from my old boss from the circus. he has been driving truck cross country for about thirty years so i thought i would try it. the screwdriver did magnetize to the back of the alternator which i think is caused by electro-magnetism, but you can't trust those circus guys. anyway, i hooked a tester to the negative post on my batt and the ground wire and tested all the fuses from the cab, but no luck. I'm just going to drive it to autozoo or o'reillys tomorrow and have them test it. as long as i disconnect my battery when i'm not driving maybe it will hold enough charge for me to start it again. i wanted to check fuses in the power distribution box, but i don't think my truck has one?
__________________
88 Ranger, fuel injected V6, Manual, dual fuel tank, Red, but I found a bill of sale in the glovebox from 2007 that stated at the time of sale the truck was silver and automatic trans. It has 190k on the odometer. I used to own an 88 red ranger when I was 19. It was only a 4 banger and had just one fuel tank. I pretty much bought it because it was a great deal and for nostalgia.
Reply With Quote
  #22  
Old 06-10-2011, 08:19 PM
Learning to use the forums
 
Join Date: Jun 2011
Posts: 5
Default Re: No start, Clicks but no turnover, Battery drains while parked?

you can test the altenator by doing this.......
while the truck is running remove the postive battery terimal from the battery and if the truck doesnt die the altenator is fine

----------

sorry I didn't see someone already said that, but i have done this plenty of times and never ever had anything mess up, my great grandfather also did this in his 50 years of is mechanic work~!
__________________
1994 Ford Ranger XLT 2WD 5 speed EXT. Cab
190xxx miles, new clutch at 178xxx
all stock
great audio system
Reply With Quote
  #23  
Old 06-10-2011, 08:21 PM
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,179
Default Re: No start, Clicks but no turnover, Battery drains while parked?

You need to check to see if your power wire from your amp to your radio is hooked up to a constant power wire. I had this same problem. I had my amp on all the time. My battery drained. I thought it was the battery and put a brand new one in there. (Since I do work at Advance) I started my truck and it started right up no problem. Well when I got home and then I let it sit over night not thinking about my amp, It drained my brand new battery. So I unhook the amp completly along with the battery and I hooked it to my battery charger over night. Next day I plug it back up and bam Fixed. I believe you have a constant power problem, and it's draining your battery. Don't get a new battery untill you check your amp.
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
  #24  
Old 06-11-2011, 03:36 PM
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 16
Default Re: No start, Clicks but no turnover, Battery drains while parked?

i disconnected the amp and left it off. went to autozoo and had the alternator tested. they said it wasn't producing enough power, so put in a new one. i didn't even have enough money for the part so they were nice enough to manually change the price for me! next i drove my truck to my buddies and hung out there for a while. went to start my truck and the battery is dead. i've been charging it all night and most of today so i'll be trying it out here real soon. if it's bad i found an old walmart battery so i'll try and exchange it. hopefully putting in the new alternator and fully charging or replacing the battery should be the end of my electric issues. i'll keep yall updated once i know for sure.

then it's on to my power steering issues...and possibly pcv valve? hearing a high pitched tone coming from that area as the engine is running. dude at autozoo said it sounds like it's coming from the pcv. just bought this truck so, i'm sure there will be plenty of work ahead of me. good thing i'm unemployed so i have plenty of time to work on it, too bad i don't got a lot of money for parts!
__________________
88 Ranger, fuel injected V6, Manual, dual fuel tank, Red, but I found a bill of sale in the glovebox from 2007 that stated at the time of sale the truck was silver and automatic trans. It has 190k on the odometer. I used to own an 88 red ranger when I was 19. It was only a 4 banger and had just one fuel tank. I pretty much bought it because it was a great deal and for nostalgia.
Reply With Quote
  #25  
Old 06-12-2011, 06:54 AM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,680
Send a message via AIM to FireRanger
Default

Your battery is probably toast. They are not.very tolerant of all that draining and charging.

[Posted with my Android mobile device using Tapatalk Pro]
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Tags
88 ranger, drained battery, electrical problem, starter

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 2.3 has power, clicks, then no power no start rumpranger 4-Cylinder Tech 2 09-02-2010 09:27 AM
2000 ranger 3.0 v6 wont start..... only clicks double00onitsnutz 3.0 Vulcan Tech 6 01-24-2010 12:04 PM
99 ford ranger wont start. new battery and had alternator checked twice (works).... pacifico t General Ford Ranger Discussion 5 10-22-2009 01:02 AM
slips down hills and on low grades while parked & in gear suzikg Drivetrain Tech 10 09-16-2009 04:52 PM
Ford Ranger won't start, doesn't appear to be a battery or fuel problem? Todd General Ford Ranger Discussion 4 12-29-2008 09:00 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.